Help with D-Link DUB-1312 USB 3-Ethernet adapter

Discussion in 'Mac Accessories' started by Miat, Jan 27, 2014.

  1. Miat, Jan 27, 2014
    Last edited: Jan 27, 2014

    Miat macrumors 6502

    Joined:
    Jul 13, 2012
    #1
    Just bought a new D-Link DUB-1312 USB 3 - Gigabit Ethernet adapter, which is supposed to work on Macs (10.6-10.8).

    Currently I get no response from it at all, none of the lights coming on or anything, and not showing up on either of my Macs (including in Disk Utility or Network Preferences).

    According to the info at D-Link the instructions to set it up on a Mac are on the CD-ROM that came with it, but I have not been able to get the CD Rom to work yet, so I can't access the instructions, and D-Link don't seem in any hurry to answer my request to supply them to me directly (via email).

    Can't find anything on Google either.

    I got it from eBay, and don't want to return it yet until I give the wisdom of MacRumours a try:

    Has anybody set one of these up on a Mac? Can you tell me how to do it?
     
  2. Miat thread starter macrumors 6502

    Joined:
    Jul 13, 2012
    #2
    D-Link supplied the software drivers, very easy install, and it is now working fine on both Macs. :) :apple:

    Case closed.
     
  3. anlu4433 macrumors newbie

    Joined:
    Aug 19, 2010
    #3
    Just bought the same adapter for my MBA. Alas, no DVD player and can't seem to find the driver online.
    Can you mail me the one you obtained? Or instruct me who to contact, what mail address?
    Send me a PM for my email!
    Cheers
     
  4. anlu4433 macrumors newbie

    Joined:
    Aug 19, 2010
    #4
    SOLVED

    Found this link. The driver worked on Mavericks 10.9
    http://support.dlink.ca/ProductInfo.aspx?m=DUB-1312
     
  5. Miat thread starter macrumors 6502

    Joined:
    Jul 13, 2012
    #5
    Apologies for not responding, I have not logged in since just before you posted that question.

    Glad you got it fixed.

    :)
     
  6. asdalavisa macrumors newbie

    Joined:
    Oct 6, 2014
    #6
    OSX Yosemite?

    Has anybody been able to get the DUB 1312 to work on 10.9 or 10.10?

    I've got it to work on a Windows with proper drivers, but it won't seem to work on 10.10.

    Any suggestions?

    Cheers!
     
  7. anlu4433 macrumors newbie

    Joined:
    Aug 19, 2010
    #7
    I haven't actually tried wired connection on Yosemite 10.10 yet.
    Will try as soon as I get home and post the results of my investigation.

    cheers all
     
  8. anlu4433 macrumors newbie

    Joined:
    Aug 19, 2010
    #8
    Home now.

    I had version driver 1.40 for DUB-1312 and it worked in both Mavericks and now Yosemite (10.9 and 10.10). Snooped around a little and found a new driver version 1.60. It's here

    http://www.dlink.com/be/nl/support/product/dub-1312-usb-3-gigabit-ethernet-adapter

    Rebooted after ver. 1.60 install and everything works fine.



    [ An important observation, really important, is that my first link from Apr 29 2014 now links to a driver version 1.00. You don't want it! ]



    Have a nice weekend all
     
  9. asdalavisa macrumors newbie

    Joined:
    Oct 6, 2014
    #9
    Thanks! Didn't realise, but i had gotten v1.4 from the Aus site, but hadn't seen v1.6

    I'll test it out tonight also, but cheers for the reply!
    :apple:
     
  10. PC_User macrumors newbie

    Joined:
    May 2, 2016
    #10
    I just wanted to confirm for others who may come across this thread.
    The above driver (v1.6) definitely DOES work with OSX 10.10.

    After you click the link provided by anlu4433 (quoted above), scroll down to Drivers, click the drop down box and select "DEU_DRV_MacOS_1_6_0_RevA."

    The description will say "Current driver for: MacOS 10.6 - 10.9," however it does work with 10.10 as well.
    The drivers that came on the installation disk did not work so you must download the above driver.
     

Share This Page