Help With Drawers in Cocoa

Discussion in 'Mac Programming' started by KillCodyDead, Jun 4, 2008.

  1. KillCodyDead macrumors newbie

    Joined:
    Jun 4, 2008
    #1
    EDIT: The problem below was fixed. However, now when I save the .nib file, and select Build and Go in Xcode, no window appears. The toolbar at the top of the screen shows that my application is running, and it appears in the dock, but no matter what I do I cannot get the main window to appear. I've tried restarting Xcode, restarting my computer, but nothing has worked so far. And no, I don't have any errors at all when compiling. Any help?



    I'm trying to build an internet browser in Cocoa. My browser will have a drawer connected to the parent window that will hold the address bar and a few buttons. When I click on NSDrawer1 in the Instances panel, I click on Connections, and then Actions. But every time I do, it just says Not Applicable. I really need to access the actions so I can connect the "Toggle:" action to a button to open and close the drawer. However, I always get the "Not Applicable" message every time I try to see the actions in the NSDrawer class.
     
  2. Krevnik macrumors 68040

    Krevnik

    Joined:
    Sep 8, 2003
    #2
    Look at the run log. There is an exception being thrown.
     
  3. KillCodyDead thread starter macrumors newbie

    Joined:
    Jun 4, 2008
    #3
    The run log just displays the "Session started at..." message.

    I just created a new project, added a drawer, and it worked. Now I'm running into a problem with the WebKit.framework, but I suppose I'll post a new thread about that.
     

Share This Page