Help with Error 1604

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Randori42, Sep 6, 2009.

  1. Randori42 macrumors newbie

    Joined:
    Mar 28, 2008
    #1
    I know there are multiple threads addressing this error code, but I cannot seem to get any of the fixes to work.

    I am using a jailbroken/unlocked 2g Iphone. I used winpwn last december to upgrade to 2.0 and have had no problems.

    Yesterday I dropped my phone and it said I needed to recover in iTunes.
    When I tried to recover it gave me error 1604.

    I am using iTunes 8 on Windows vista.

    I have tried using an older version of iTunes, changing USB ports, removing SIM card...etc...

    The screen stays blank no matter what I do unless I plug it in. I plugged it in and put in DFU mode... attempted recovery. Now when I plug it in I get a cartoon that looks like Steve Jobs with a russian text box?

    I am assuming this is a graphic from winpwn?

    Am I missing an obvious fix?

    I've always found my answers here in the past.. so here's hoping
     
  2. johnbrunetti macrumors newbie

    Joined:
    Nov 17, 2009
    #2
    I have the same problem

    I have the same problem, and to date, you are the only other person I have found that has the same problem. I don't know the answer. I need some help with this stuff as well
     
  3. -aggie- macrumors P6

    -aggie-

    Joined:
    Jun 19, 2009
    Location:
    Where bunnies are welcome.
    #3
  4. kAoTiX macrumors 6502

    kAoTiX

    Joined:
    Oct 14, 2008
    Location:
    Midlands, UK
    #4
    You know what sucks. I have had this problem on a number of iPods and an iPhone recently and I have actually resolved it once out of about 50 times.

    I recently got an iPod to refurbish and sell on and upon restoring to 3.1.2 it did the old 1604 on me. I thought fuuuuuuuuuuuuuuuuuuuuuuuuuu
    I was ready to just throw it on eBay as faulty and get rid of it.

    I had, however just re-installed XP SP2 onto my laptop and installed iTunes totally fresh. I plugged in the iPod and got the same 1604 again. After leaving my laptop on, it told me there were some updates available (The usual crap, this was an SP2 disk after all) and it installed IE 8 as well.
    I then, randomly, tried to restore again. To my amazement I got the little progressbar on the iPod and was just totally gobsmacked. For the next 10-15 mins I didnt look away from the iPod and iTunes and it worked.

    But saying that, it doesn't work on any others I've tried! It's soooo stupid.
    All that I know now is that it is possible to restore them and it's not bricked but the method to fix is like winning the lottery with the numbers 1 2 3 4 5 and bonus ball 6 :rolleyes:
     

Share This Page