Help with external HD - MyBook 500GB

Discussion in 'Mac Basics and Help' started by Zephyras, Sep 23, 2008.

  1. Zephyras macrumors newbie

    Joined:
    Sep 23, 2008
    #1
    Hi there, long time reader, first time poster.

    For no apparent reason, my external HD has decided to stop working...Everytime I plug it via firewire, an error message pops up -

    "The disk "my book" was not repairable by this computer. It is being made available to you with limited functionality. You must back up your data and reformat the disk as soon as possible"

    Here lies my problem, I'd gladly reformat it, if it weren't for the fact I don't have anywhere to "back up my data" to! I've got a 1st gen Macbook pro with only 10G spare on the HD, the external HD has 300gb worth of irreplaceable material..

    So, anyone have any ideas :) ?
     
  2. blodwyn macrumors 65816

    Joined:
    Jul 28, 2004
    Location:
    Portland, Oregon
    #2
    3 choices as I see it:
    1. Buy or borrow a new disk to back up the irreplaceable data to
    2. Decide the data is not irreplaceable and reformat the MyBook
    3. Live with the current scenario

    I'd vote for number 1
     
  3. smogsy macrumors 6502a

    Joined:
    Jan 8, 2008
    #3
    you tried running diagnostic tools on your external wd? they came preinstalled on my wd hardrive in a Tools Folder
     
  4. 840quadra Moderator

    840quadra

    Staff Member

    Joined:
    Feb 1, 2005
    Location:
    Twin Cities Minnesota
    #4

    Not sure about this one, it could be one of many things. One thing that may help is to get the output of a Disk Utility disk repair to either Western Digital or Apple.

    Have you tried to run repair within Disk utility ?

    Applications > Disk Utility > (Select your WD Drive) > Repair Disk.

    What does it output on the diagnostic screen?

    [​IMG]
     
  5. ebel3003 macrumors 6502a

    ebel3003

    Joined:
    Jun 20, 2007
    Location:
    "The Google"
    #5
    If you set up an 'Advanced RMA' with Western Digital, they will send you a new drive, which you can use to transfer your data to before sending back the failing drive.
     
  6. fastfalco382 macrumors newbie

    Joined:
    Sep 27, 2008
    #6
    Having a similar problem as the topic starter with a WD Passport 500gb.. can anyone help out?

    the disk was not repariable by this computer. it is being made avaliable to you with limited functionality. you must back up your data and reformat the disk as soon as possible.

    i tried using disk utility to repair the disk but i got "Error: Filesystem verify or repair failed." Is there anyway that I can fix this without having to ask for a new drive and transferring?
     
  7. garfinkel macrumors newbie

    Joined:
    Dec 29, 2003
    Location:
    Philadelphia
    #7
    same problem

    over the past two months, i've had the same problem twice -- once with an older external drive, and one that was just purchase after the first incident.

    this makes me think it has something to do with the OS.

    here is the odd thing. after the second drive gave me problems today, i dug up the older drive just to test things out. the older drive gave me the same message. HOWEVER, months ago, i was unable to access any of the files. today, all of the files are fine! and when i ejected it, and plugged it back in, it no longer gave me an alert.

    sooo.... it seems as if the older drive that had this problem months ago is suddenly back to normal with no problems.

    very strange.

    so... everyone out there with drives that have critical files on them -- DO NOT erase the drive. because clearly the answer to the problem is not a new drive or reformatting. it seems this problem will reoccur until Apple fixes the issue.

    my gut feeling is that the data is fine and that the problem has to do with how the OS is recognizing data/drive.

    i suggest testing the drive on various machines that have different versions of the OS.

    good luck. i hope this bit of bad news/good news helps.
     

Share This Page