Help with External HD Permissions

Discussion in 'Mac Basics and Help' started by azoo711, Jun 9, 2012.

  1. azoo711 macrumors newbie

    Joined:
    Jun 9, 2012
    #1
    Hi,

    I recently sent my 2010 Macbook Pro out for repairs (from a company other than Apple - mistake, but nevermind that).

    They ended up replacing my hard-drive which is all fine and dandy, except now I'm having issues reading and writing to my external hard drive.

    The external was used with the same computer I'm using now (mac) so I don't think it's a matter of it being formatted to a different system.

    I noticed yesterday that certain backups (my Blackberry backups, for example) are displaying on the external HD as a folder with a small red - sign next to it. Also, when attempting to write certain files to the external I'll get messages like "The item “img003.tif” can’t be moved because “Scans” can’t be modified." with the option of "Authenticate" or "Cancel." "Authenticate" allows me to write to the disk, but this is not something I have encountered before when I had my old HD in this computer.

    I've attempted repairing permissions on both my HD and the External, but this keeps happening. Sharing & Permissions on the external says I can read and write, but I'm still having issues. Any ideas? Do I need to reformat the entire external HD? Figured I'd ask here before doing that since it's a 2tb and it'll take forever...
     
  2. monokakata macrumors 68000

    monokakata

    Joined:
    May 8, 2008
    Location:
    Hilo, Hawai'i
    #2
  3. azoo711 thread starter macrumors newbie

    Joined:
    Jun 9, 2012
    #3

    The terminal method worked, thank you very much!
     
  4. azoo711 thread starter macrumors newbie

    Joined:
    Jun 9, 2012
    #4
    Upon closer inspection, it hasn't actually worked - I didn't realize how wonky everything was ESPECIALLY when I'm trying to access my backups via timemachine. I don't have permission to view anything when I'm trying through there. Help?
     

Share This Page