help with external iphoto Mnt. lion / snow leopard

Discussion in 'Mac Apps and Mac App Store' started by msugarpants, Oct 22, 2012.

  1. msugarpants macrumors member

    Joined:
    Jan 4, 2005
    #1
    Here's the deal. I had a MBP with snow leopard die. it was suffered damage to the logic board. I took out the drive, placed it in a dock, and am trying to move the iphoto library/data to an external drive connected to a mac mini running Mnt. Lion. That wont work. error message says something like it cant be moved. OK. Then I try to open the iphoto library (9.2 i think) on the mac mini from the original drive i took out of the MBP. it wont open. First off.....why cant I drag the iphoto library to an external drive? AHHH...Secondly:

    1) should I download a fresh, new version of iphoto to the mini, and open the old library on the original drive i took out of the MBP?

    2) downgrade Mnt Lion (since its a fairly new install for me) to Snow Leopard, and try n open it from there?

    3) your best guess?

    I spent the last 6 years organzing 29,000 photos and tagging them all. My kids lives are documented here. I simply cannot afford to start over. There must be a way.

    Thanks-mike
     
  2. divideby, Oct 22, 2012
    Last edited: Oct 22, 2012

    divideby macrumors member

    Joined:
    Sep 16, 2009
    #2
    Sorry to hear you're having issues, i definitely know what it's like to not want to start over a project you've been working on for six years.

    Try running disk utility "verify disk" on the sledded drive. Repair it if it is corrupted.

    Is it just the iPhoto library that doesn't move, or do other files move ok?

    Try not dragging it to the external drive connected to Mac Mini, and just dragging it to the internal drive. I've seen this issue appear on certain external drives.

    What makes you think that the logic board died? Sometimes a failing disk can be misdiagnosed as logic board failure (slow boot, boot chime but stuck at grey screen, progress bar at startup). Disk repair should figure out if it's the drive.

    If the drive is failling, open terminal and use a ditto command.

    ditto -V "drag iphoto library folder onto terminal screen" "drag destination folder onto terminal screen"

    no quotes. it might take a lot of time to do this and may appear unresponsive.

    edit:

    In regards to your OS questions, the likelihood that you cannot open the library folder because of an OS is low. If you open on Mountain Lion it will automatically upgrade the iPhoto library. iPhoto from what it sounds like is not able to read the iphoto library, again pointing to an issue with the drive.
     
  3. msugarpants thread starter macrumors member

    Joined:
    Jan 4, 2005
    #3
    Thanks Divideby,

    Logic board has corrosion. Musta gotten wet. its not too much, but its enough that it wont boot and it shuts down quick. but thats really not even relevant (although, thanks for the suggestions on that. I will tackle fixing that later). So, therefore, I dont think terminal can help me here, can it?

    I have a 320gb drive in the mini with only 50 empty. I photo is 300 gigs! I will try disk utility for the original drive. But, while it was in the MBP, it worked just fine, so i dont think thats an issue. The destination drive I wiped clean.

    Can I just put the MBP drive in the mac mini and expect it to boot and work? if so....i will do that

    here is some other info that might help: my mini did not have iphoto on it. I dragged the app from my applications folder of the MBP drive to the mini, thinking it would open. Many of my other apps did open that way. But, maybe this one wont? thats why i thought about a new app store install of iphoto! What do you think?

    ----------

    i did not open iphoto on the mac mini from a dmg file! could that be it? before hand, i had no iphoto on there and I just tried opening it through the app i dragged over. dont know why i did not think of this.....3pm cant come soon enough.
     
  4. msugarpants thread starter macrumors member

    Joined:
    Jan 4, 2005
    #4
    additional thoughts:

    I did not attempt to load iphoto onto the mini via a DMG. I did it through the app itself that i dragged over from the other hard drive. So, maybe if i do the former, it will help. HOWEVER.....that still wont explain why i cant drag the iphoto contents over to a new external drive! argh! please, anything will help:confused:
     
  5. flynz4 macrumors 68040

    Joined:
    Aug 9, 2009
    Location:
    Portland, OR
    #5
    Have you been running Time Machine or other backups? That is the most obvious way to recover.

    From what you wrote... I would speculate that your HDD is corrupted or damaged. I think running the disk verify and repair options are good advice.

    Before doing anything... I would attempt cloning the drive to another blank HDD. You do not want to risk damaging your sole existing copy. If it will not clone, then that is another indication that the HDD has failed.

    Your final option might be to use a disk recover service... but that can be quite expensive.

    /Jim
     
  6. msugarpants thread starter macrumors member

    Joined:
    Jan 4, 2005
    #6
    after more twists and turns than you care to hear, I have three things going on.
    1) the original disk was corrupt and unrepairable...but i was able to drag most of it off one folder at a time...all except....
    2) the folder called faces inside database folder inside iphoto contents is where the iphoto corruption is. error code -36. I am working through this as we speak to figure out what happens when i get everything else working
    3) i finally was able to get iPhoto 9.4.1 onto the mac mini/mnt lion drive! but when i open the original iphoto library while holding option on the other drive, it says i do not have permission. Yet, it is unlocked and set so that I DO in fact have permission. This may have something to do with the error i kept getting.

    so, the new plan is....well....I dont know. I can drag almost all the contents from iPhoto onto an external drive, but not the original iPhoto container. if i can hand drag each of them into a new library i create on an external drive, i think that may work. This has been a long 7 hours today....and about the same yesterday fixing this mess!

    Tell me what you think.

    thanks again, flynz and divideby.
     
  7. divideby macrumors member

    Joined:
    Sep 16, 2009
    #7
    Good to see that you've had some luck at least!

    You definitely want to get a good dmg of iPhoto because there are folders pertaining to iPhoto in the /Libary folder which you may not have grabbed. If you had grabbed them, there is no telling if that would work. Sounds like you got a good copy.

    Just an FYI, terminal still can help you out. Ditto is basically a copy command, except that where copy may generally error out, ditto will attempt to move it anyway, and if a file cannot be moved due to a hardware issue or otherwise it will move on to the next. It's basically what you're doing manually. You are skipping files that cannot transfer, ditto will do the same. If it gives you permission errors, you could perform a sudo ditto -V. Ditto it will write 99% of a file that is corrupted, where as the copy command will not copy that file.

    I think that the software corruption on the drive is stopping you from moving data over. If you have access to a copy of Disk Warrior, I would run that to try and fix the sledded drive. It generally can fix all errors unless the drive is mechanically failling. (I don't think it is).

    Repeated shutdowns (maybe due to logic misfiring) could cause some corruption on your hard drive that is unrepairable. It could also be if you're not "ejecting" the sledded drive (most common). Also frankly it might just have happened for no reason. I don't think it's mechnically failing (good news) as you probably wouldn't have gotten as far as you have. Disk warrior should fix it.

    I would not put it in your mac mini and boot off of it, as it may not understand the hardware of your mini and it could be a pain to do depending on the model.


    Once it's moved, and you option click and choose that library, close iPhoto. Reopen it and hold command & option while clicking on iPhoto to open it. it will give you the option to repair the database as well as permissions, that may help.
     
  8. msugarpants thread starter macrumors member

    Joined:
    Jan 4, 2005
    #8
    Success! iphoto 9.4.1 on the mini with the library fully intact and working on an external drive. Anyone got iPhoto problems? I am your man, hahaha. Thanks for the tips, DB. and Fly.

    http://ochelp.custhelp.com/cgi-bin/...std_adp.php?p_faqid=1615&p_created=1306246498

    This page is what saved me. I googled the error code (-36) and figured out to manually move everything. i dont know why i did not think of showing the contents before! the iphoto icon is just a container. I knew the files had to be there somewhere. I found the file, in faces, causing an error....but it copied over fine, one i did it by sub folders. I will follow your directions next time with termimal. Sounds great. and that final note you said on repairing the library is quite helpful. I will run disk warrior when I get a copy of it. I think i have an old one i can try in the meantime. Maybe i can repair the mbp drive. Of course, since i had damage to the logic board, it wont do me much good. Thats my next big project to tackle.....repair the logic board via youtube vids (alcohol, distilled water, and an oven ironically) and piece the MBP back together. if it doesn't work, i have lost nothing. Now to back up everything I own!
     
  9. divideby macrumors member

    Joined:
    Sep 16, 2009
    #9
    WOOT! Good to hear!
     
  10. flynz4 macrumors 68040

    Joined:
    Aug 9, 2009
    Location:
    Portland, OR
    #10
    I am very happy that you figured this out. Congratulations.

    You learned some new technical tricks along the way. Hopefully the bolded section above was your biggest learning!!! You dodged a bullet. Congrats!

    /Jim
     

Share This Page