Help with extracting Couchsurfer files after transfer to my Atv

Discussion in 'Apple TV and Home Theater' started by qwertyuiop7, Feb 20, 2009.

  1. qwertyuiop7 macrumors newbie

    Joined:
    Feb 20, 2009
    #1
    Struggling to load couchsurfer onto my new Apple TV.
    Loaded with the latest 2.3 update.
    Very latest Atvusb-creator and Boxee

    First thing i need to let you know is i havn't got a clue about ssh, ftp, terminal windows, hacking etc all i am doing is following word for word instructions found on this forum, the Boxee forum and the wiki on AwkwardTV.
    http://wiki.awkwardtv.org/wiki/Couchsurfer

    All of which has worked very well until now

    Contact made with the Atv ok , used Fugu to do the file transfers from my powerbook to the Atv users/frontrow directory OK and using Terminal to input the commands to navigate to the directory and to try and extract the
    Plugin tarball.
    Wiki says to use the following command to extract the file
    tar -xvzpf couchsurfer-0.6-2.x-bin.tar.gz
    See cut and paste from my terminal window below for error message i get

    Last login: Thu Feb 19 23:24:44 on ttys000
    Macintosh:~ philipsmith$ ssh frontrow@192.168.1.4
    Welcome to the AppleTV (via atv-usbcreator)
    frontrow@192.168.1.4's password:
    -bash-2.05b$ cd /Users/frontrow/
    -bash-2.05b$ tar -xvzpf couchsurfer-0.6-2.x-bin.tar.gz

    tar (child): couchsurfer-0.6-2.x-bin.tar.gz: Cannot open: No such file or directory
    tar (child): Error is not recoverable: exiting now
    tar: Child returned status 2
    tar: Error exit delayed from previous errors
    -bash-2.05b$



    File name matches the file fugu has copied and location is correct

    Any ideas what i am doing wrong


    Thanks

    Phil
     
  2. jpfisher macrumors regular

    Joined:
    Dec 5, 2006
    Location:
    New Jersey
    #2
    If you downloaded the CS files via Safari, they won't work -- Safari automatically unzips the GZ file into a straight TAR. Download with Firefox, transfer those files to the ATV, and that should fix the problem.

    Also, during the step where you move the extracted Couch Surfer to the Finder.app, you may get a permission denied error. Add "sudo" to the beginning of the command (the instructions are blocked here at work, but type sudo, space, and then paste the command off of the wiki page) -- it will prompt you for your password at this point, but it gets it working.

    If you're expecting to use CS to watch Hulu... good luck. I got Flash working and everything last night, but performance was unacceptable on the ATV.... and there's no way to full screen the player with CouchSurfer -- the browser's implementation of a mouse won't pass a click onto the flash player.
     
  3. qwertyuiop7 thread starter macrumors newbie

    Joined:
    Feb 20, 2009
    #3
    Thanks for the super fast response, Just tried it via Firefox and it works fine.
    You were also correct about the next command it did need to be

    sudo mv CouchSurfer.frappliance /System/Library/CoreServices/Finder.app/Contents/PlugIns/

    I am from the UK and can't access Hulu so i won't be a problem.
    I just fancied the option of another way to browse the net whilst the wife is busy hogging the laptop:)

    Thanks again

    Phil
     

Share This Page