Help with Gskill SSD

Discussion in 'MacBook Pro' started by kalex, Oct 29, 2010.

  1. kalex macrumors 65816

    Joined:
    Oct 1, 2007
    #1
    Hello,
    I recently bought GSkill Phoenix Pro 120GB SSD that I wanted to install into my Mid 2010 macbook pro

    I'm having problems getting it detected by macbook pro when its instlalled into the HDD space.

    Here is what I did:
    1) Connected SSD via USB to SATA adapter. It got detected by OSX and I was able to use superduper to clone my 250GB HDD to SSD
    2) shutdown macbook pro and swapped HDD for SSD.
    3) after my macbook pro powered on, it keeps sitting at grey screen without apple logo. It looks like its not detecting the SSD at all

    So I decided to try using external hard drive as a go between.
    I superdupered my internal HDD to external HDD and installed SSD again.
    Upon booting i got the grey screen again and was able to boot only by doing Option+Command+Shift+Delete to boot of external HDD

    I also tried PRAM zap with same result

    Any ideas of what might be the problem and how to fix it? SSD seems to be working because I was able to see it via sata to usb adapter

    SSD I have is:
    GSkill Phoenix Pro 120GB Model: FM-25S2S-120GBP2


    Any help is greatly appreciated


    Thanks

    Alex
     
  2. kalex thread starter macrumors 65816

    Joined:
    Oct 1, 2007
  3. Reelknead1 macrumors 6502

    Joined:
    Sep 21, 2009
    #3
  4. Lambros macrumors regular

    Joined:
    Feb 24, 2010
    Location:
    Sydney, Australia
    #4
    When you boot from the OS X installation DVD and go to Utilities -> Disk Utility, is the new drive located down the left hand column?
     
  5. superericla macrumors 6502

    Joined:
    Sep 27, 2010
    #5
    Did you make sure to partition the drive as hfs+ with the right partition type before using it?
     
  6. kalex thread starter macrumors 65816

    Joined:
    Oct 1, 2007
    #6
    @Reelknead1 - did that, and nothing happened with ssd installed. just sitting at grey screen without apple logo.

    @Lambros - disk utility doesn't see the SSD

    @superericla - did that when it was connected via USB. after it was done I was able to superduper to it, but after i installed it internally it didn't get detected. Very strange
     
  7. Reelknead1 macrumors 6502

    Joined:
    Sep 21, 2009
    #7
    That is really strange. The drive is partitioned OSX Journaled Extended is it not?

    Also check to make sure all your connections are seated properly. If disk utility is not seeing it, most likely a physical issue. I've never heard of an SSD not being compatible with OSX but it might be worth looking into.
     
  8. kalex thread starter macrumors 65816

    Joined:
    Oct 1, 2007
    #8
    I think i found the problem but its really weird one.

    When I tried installing "one more time" :) i noticed the sata connector on the macbook pro doesn't completely cover the SSD connector.
    When I flipped the drive upside down, I saw SSD sata connector exposed by about 1mm.
    i think that the case of the SSD and its connector are a bit off and are not making proper contact with sata cable of my macbook.
    I just installed same SSD into my Mac Pro and it detected it without any issues. Disk utility sees it and I'm currently running CCC.
    Will try to boot it after CCC is done.

    Update:

    CCC finished and Mac Pro booted from SSD with flying colors and very fast. Very strange. I guess casing of this model is a bit off for macbook
     
  9. Ptyger macrumors member

    Ptyger

    Joined:
    Nov 20, 2008
    Location:
    Knoxville, TN
    #9
    That is strange. I have the exact same drive in my mid-2009 15" MBP. I didn't try to clone my old drive, however, just installed a new copy of Snow Leopard from scratch. Maybe try that, and then use migration assistant to move your data over?
     
  10. kalex thread starter macrumors 65816

    Joined:
    Oct 1, 2007
    #10
    it is possible that my drive doesn't allign properly but problem is i don't have anything to compare it to. Drive works great in my Mac Pro. Day 2 with no problems :)
     
  11. jayeatworld macrumors newbie

    Joined:
    Nov 5, 2010
    #11
    MacBook

    I'm getting this exact drive next week for my old MacBook (late 2006). I'll move it to an iMac i7 when I upgrade by the end of the year.

    Could the problem be with CCC? If Disk Utility can't detect the drive does that mean it's using an unsupported partition?

    I hope I don't run into any problems. I'll update this thread as soon as I install it. :)
     
  12. kalex thread starter macrumors 65816

    Joined:
    Oct 1, 2007
    #12
    Update -- Turns out my ssd was defective. It completely died after 26 hours in my Mac Pro

    I guess reviews on newegg are correct. QA is lacking
     
  13. sbddude macrumors 6502a

    Joined:
    Sep 27, 2010
    Location:
    Nor Cal, USA
    #13
    I recommend the OCZ Vertex 2. No issues in my MBP.
     
  14. nsx23 macrumors member

    Joined:
    Nov 8, 2010
    #14
    Hmm, not good to hear about. I have an older G.Skill Falcon 2 in my Macbook pro.
     

Share This Page