iPhone Help with HTML lockscreen

Discussion in 'Jailbreaks and iOS Hacks' started by eddyecb, Apr 10, 2013.

  1. eddyecb macrumors regular

    Joined:
    Sep 19, 2012
    #1
    Hi there, I need help with an HTML lock screen, LS jelly bean for iPhone 5 to be exact. I want to remove the lockbackground.png from the theme so I'm able to set a wallpaper as usual for lock screen and springboard. Any one able to help? Thanks!
     
  2. nanolife macrumors 6502

    nanolife

    Joined:
    Sep 20, 2011
    Location:
    Pasadena
    #2
    Remove the line inside lockbackground.html that refers to the .png file.

    Share the html and I will remove it for you.
     
  3. eddyecb, Apr 10, 2013
    Last edited by a moderator: Apr 15, 2013

    eddyecb thread starter macrumors regular

    Joined:
    Sep 19, 2012
    #3
    Thanks for the reply. I did that, but after respringing its just a black screen.
    Heres the lines that refer to the images tho:
    <html><head>

    <link rel="stylesheet" href="Style.css" type="text/css" media="screen" />

    <img src="LockBackground.png" style="position: absolute; top: 0px; left: 0px; width: 320px; height: 568px; z-index:-5;"/>

    <img src="Overlay.png" style="position: absolute; top: 0px; left: 0px; width: 320px; height: 480px; z-index:-5;"/>
     
  4. nanolife macrumors 6502

    nanolife

    Joined:
    Sep 20, 2011
    Location:
    Pasadena
    #4
    Remove this line: <img src="LockBackground.png" style="position: absolute; top: 0px; left: 0px; width: 320px; height: 568px; z-index:-5;"/>

    Probably above these lines theres a color-background set, you need to remove that too.
    Something like:


    body {
    background-color:#1E1E1E; (REMOVE THAT)
    color: #ffffff;
    }
     
  5. eddyecb, Apr 10, 2013
    Last edited by a moderator: Apr 15, 2013

    eddyecb thread starter macrumors regular

    Joined:
    Sep 19, 2012
    #5
    No back ground colour in the .css :confused: im stumped!
     
  6. nanolife macrumors 6502

    nanolife

    Joined:
    Sep 20, 2011
    Location:
    Pasadena
    #6
    Not in the css, inside the html.
     
  7. eddyecb, Apr 10, 2013
    Last edited by a moderator: Apr 15, 2013

    eddyecb thread starter macrumors regular

    Joined:
    Sep 19, 2012
    #7
    Nope, not in there either...
     
  8. nanolife, Apr 10, 2013
    Last edited: Apr 10, 2013

    nanolife macrumors 6502

    nanolife

    Joined:
    Sep 20, 2011
    Location:
    Pasadena
    #8
    Share the html file and let me check. :)

    Edit: Remove the <img src="Overlay.png" style="position: absolute; top: 0px; left: 0px; width: 320px; height: 480px; z-index:-5;"/>

    Edit 2: I just downloaded that LS and did exactly how I told you and it is working fine for me.

    Try setting the wallpaper once again.
     
  9. eddyecb, Apr 10, 2013
    Last edited by a moderator: Apr 15, 2013

    eddyecb thread starter macrumors regular

    Joined:
    Sep 19, 2012
    #9
    here is the entire theme lol
    https://www.dropbox.com/sh/af62x52e1ruvp89/NHXJE72sZS
     
  10. nanolife macrumors 6502

    nanolife

    Joined:
    Sep 20, 2011
    Location:
    Pasadena
    #10
    It is free in Cydia, I downloaded already and removed the two strings I told you about:

    <img src="LockBackground.png" style="position: absolute; top: 0px; left: 0px; width: 320px; height: 568px; z-index:-5;"/>

    <img src="Overlay.png" style="position: absolute; top: 0px; left: 0px; width: 320px; height: 480px; z-index:-5;"/>

    Also removed the lockbackground.png, Overlay.png and lockbackground-ALT.png, saved the file, went to Settings and set another wallpaper for lockscreen, done!

    Edit: Here, I edited the file for you: https://www.dropbox.com/s/27jbei5cg47h3ns/LS Jelly Bean i5.zip

    Download it and put inside Winterboard or LockHTML2 and it will work flawless. Remember to set the desired wallpaper on Settings.
    If that doesn't work, install Wallpaper JPEGifier from Cydia and set the wallpaper again.
     
  11. eddyecb, Apr 10, 2013
    Last edited by a moderator: Apr 15, 2013

    eddyecb thread starter macrumors regular

    Joined:
    Sep 19, 2012
    #11
    Thanks for that altho it still hasn't worked! Still get a black screen on the lockscreen

    EDIT: didnt see the last bit, will try and report back!

    EDIT2: Nope still nothing, so confused.
     
  12. nanolife macrumors 6502

    nanolife

    Joined:
    Sep 20, 2011
    Location:
    Pasadena
    #12
    It works fine for me. Are you sure there's no other theme enabled? Are you using winterboard or LockHTML2?
     
  13. eddyecb, Apr 10, 2013
    Last edited by a moderator: Apr 15, 2013

    eddyecb thread starter macrumors regular

    Joined:
    Sep 19, 2012
    #13
    Yep, definitely no other themes on and winterboard. I dont understand at all
     
  14. nanolife macrumors 6502

    nanolife

    Joined:
    Sep 20, 2011
    Location:
    Pasadena
    #14
    Are you sure you are saving the file and uploading to the same location?
    Respringing Winterboard after? Show me a screenshot of your LS.
     
  15. eddyecb, Apr 10, 2013
    Last edited by a moderator: Apr 15, 2013

    eddyecb thread starter macrumors regular

    Joined:
    Sep 19, 2012
    #15
  16. nanolife macrumors 6502

    nanolife

    Joined:
    Sep 20, 2011
    Location:
    Pasadena
    #16
  17. eddyecb, Apr 10, 2013
    Last edited by a moderator: Apr 15, 2013

    eddyecb thread starter macrumors regular

    Joined:
    Sep 19, 2012
    #17
    Still nothing! I give up, i really appreciate your help tho :)
     
  18. nanolife macrumors 6502

    nanolife

    Joined:
    Sep 20, 2011
    Location:
    Pasadena
    #18
    Yeah, that's probably something else. If I was you, I would try removing Winterboard and all themes, use iCleaner after and then removing everything from /var/mobile/Library/Caches and rebooting the device and only then reinstall everything.

    If that doesn't work, you have something else going on. :p
     
  19. ominx macrumors 6502

    Joined:
    Jun 23, 2010
    #19
    Install JPEGifier if you haven't already and set your Lock Screen Wallpaper from Settings App.

    Then...

    Change

    <img src="LockBackground.png" style="position: absolute; top: 0px; left: 0px; width: 320px; height: 568px; z-index:-5;"/>

    to

    <img src="/var/mobile/Library/SpringBoard/Converted-LockBackground.jpg" style="position: absolute; top: 0px; left: 0px; width: 320px; height: 568px; z-index:-5;"/>
     
  20. eddyecb, Apr 10, 2013
    Last edited by a moderator: Apr 15, 2013

    eddyecb thread starter macrumors regular

    Joined:
    Sep 19, 2012
    #20
    Worked like a charm! Thank you and thanks to nanolife aswell! :D
     

Share This Page