Help with iPhone 4 please!!!!!

Discussion in 'iPhone Tips, Help and Troubleshooting' started by MrTechDude93, Dec 2, 2010.

  1. MrTechDude93 macrumors newbie

    Joined:
    Dec 2, 2010
    #1
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 4_1 like Mac OS X; en-us) AppleWebKit/532.9 (KHTML, like Gecko) Version/4.0.5 Mobile/8B117 Safari/6531.22.7)

    I have a iPhone 4, jailbroke, 4.1 on AT&T prepaid, when I have 3G or edge turned on it costs me random charges for doing nothing, so I keep both turned off and I can still text and call fine, my question is why can't I send or recieve picture messages with 3G and edge off? If I want to send or recieve pics I have to turn them both on, why is this? Is there a way around it? Is it like this on all iPhones? When I first got it and activated it I used it on edge and it all worked fine, pics, videos everything and I never got charged, then I used that APN changer website and it didn't work so I tried to uninstall through their website and it said on iOS 4 all you have to do is go to settings and turn off cellular data, I did but now no pics, someone please help out, should I just restore my iPhone and avoid the APN changer website? Thanks for any help, Ethan.
     
  2. Intell macrumors P6

    Intell

    Joined:
    Jan 24, 2010
    Location:
    Inside
    #2
    All phones use the EDGE/3G/EVDO/Data to send and receive MMS. Some plans have MMS as part of the texting even though they have data blocked on their account. As per the random data charges, all iPhones and maybe even all smart phones do this. They are internet devices and it's just something that can't easily be stopped.
     
  3. MrTechDude93 thread starter macrumors newbie

    Joined:
    Dec 2, 2010
    #3
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 4_1 like Mac OS X; en-us) AppleWebKit/532.9 (KHTML, like Gecko) Version/4.0.5 Mobile/8B117 Safari/6531.22.7)

    So are you trying to say in order to send or recieve pics or vids I have to turn 3G/edge on?
     
  4. eawmp1 macrumors 601

    eawmp1

    Joined:
    Feb 19, 2008
    Location:
    FL
    #4
    Yes
     
  5. MrTechDude93 thread starter macrumors newbie

    Joined:
    Dec 2, 2010
    #5
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 4_1 like Mac OS X; en-us) AppleWebKit/532.9 (KHTML, like Gecko) Version/4.0.5 Mobile/8B117 Safari/6531.22.7)

    Alright. Thanks.
     

Share This Page