Help with iphone, error message 'you are not subscribed to edge'

Discussion in 'iPhone Tips, Help and Troubleshooting' started by jamesarm97, Jan 5, 2008.

  1. jamesarm97 macrumors 65816

    Joined:
    Sep 29, 2006
    #1
    Can anyone help me or has anyone seen this before? I have not done anything lately, but now I get an error message when I try and go to the web. It says:

    Could not activate EDGE: You are not subscribed to EDGE.

    I checked my AT&T account and everything looks correct. It has only started since yesterday. I have reset the phone and it does not fix it. Is there somewhere the username and password is stored for Edge or is it an AT&T thing?

    I have full signal strength and the Edge icon. I turned Edge off then back on in the settings and that does not help.

    On an AT&T account with iphone data plan.

    - James
     
  2. marcelo002 macrumors member

    Joined:
    Jul 18, 2002
    Location:
    Owego, NY
    #2
    Is your iPhone jailbroken? I had the same issue a couple weeks ago. I fixed it by installing the third-party application "Services" and turning edge off and then back on. It told me something about incorrect settings, asked me to pick my carrier, and that fixed it for me. Good luck.
     
  3. jamesarm97 thread starter macrumors 65816

    Joined:
    Sep 29, 2006
    #3
    I just tried that and it did not work. Did not prompt me for any settings. I have a valid AT&T account. The iPhone is jailbroken 1.1.2, I can't really remember doing anything recently that would of changed anything. I looked at the ATT_US file (/system/library/frameworks/coretelephony.framework/support/ATT_US):

    Everything looks ok there as in username password. AT&T support is closed until monday which I think is stupid.

    Thanks,
    James

    <?xml version="1.0" encoding="UTF-8"?>
    <!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
    <plist version="1.0">
    <dict>
    <key>BookmarkURLs</key>
    <array>
    <dict>
    <key>BookmarkName</key>
    <string>AT&T MyAccount</string>
    <key>BookmarkURL</key>
    <string>https://www.wireless.att.com/my-account</string>
    </dict>
    </array>
    <key>CarrierName</key>
    <string>AT&T</string>
    <key>IntlDataRoamingSwitch</key>
    <true/>
    <key>MyAccountURL</key>
    <string>https://www.wireless.att.com/my-account</string>
    <key>MyAccountURLTitle</key>
    <string>AT&T MyAccount</string>
    <key>Services</key>
    <array>
    <dict>
    <key>ServiceCode</key>
    <string>*225#</string>
    <key>ServiceName</key>
    <string>Check Bill Balance</string>
    </dict>
    <dict>
    <key>ServiceCode</key>
    <string>411</string>
    <key>ServiceName</key>
    <string>Directory Assistance</string>
    </dict>
    <dict>
    <key>ServiceCode</key>
    <string>*729</string>
    <key>ServiceName</key>
    <string>Pay My Bill</string>
    </dict>
    <dict>
    <key>ServiceCode</key>
    <string>*646#</string>
    <key>ServiceName</key>
    <string>View My Minutes</string>
    </dict>
    <dict>
    <key>ServiceCode</key>
    <string>*08</string>
    <key>ServiceName</key>
    <string>Voice Connect</string>
    </dict>
    </array>
    <key>ShowCallForwarded</key>
    <false/>
    <key>ShowCallForwarding</key>
    <false/>
    <key>ShowDialAssist</key>
    <true/>
    <key>ShowTTY</key>
    <true/>
    <key>StockSymboli</key>
    <array>
    <dict>
    <key>name</key>
    <string>AT&T</string>
    <key>symbol</key>
    <string>T</string>
    </dict>
    </array>
    <key>SupportedSIMs</key>
    <array>
    <string>310150</string>
    <string>310170</string>
    <string>310180</string>
    <string>310380</string>
    <string>310410</string>
    <string>310980</string>
    <string>311180</string>
    </array>
    <key>SupportsNITZ</key>
    <true/>
    <key>VVMIgnoresIntlDataRoaming</key>
    <true/>
    <key>VisualVoicemailServiceName</key>
    <string>ACDS</string>
    <key>apns</key>
    <array>
    <dict>
    <key>apn</key>
    <string>wap.cingular</string>
    <key>password</key>
    <string>CINGULAR1</string>
    <key>username</key>
    <string>WAP@CINGULARGPRS.COM</string>
    </dict>
    <dict>
    <key>apn</key>
    <string>acds.voicemail</string>
    <key>password</key>
    <string></string>
    <key>username</key>
    <string></string>
    </dict>
    </array>
    <key>voicemail_context</key>
    <integer>1</integer>
    </dict>
    </plist>
     
  4. droolerk9 macrumors newbie

    Joined:
    Jan 17, 2008
    #4
    iPhone you are not subscribed to EDGE

    I also had this error and a problem with SMS. Upon reviewing my GoPhone account on the AT&T web site, the two features are listed as inactive. This seems to have ocurred when the 1.1.3 update was installed. If you call customer service (611) they can restore the settings. AT&T claims that Apples software caused the problem and since the updates release they have been noting this problem.

    The text messaging will work, but it costs $0.15 for each message without the service being activated.
     

Share This Page