Help with Java and running a webclient

Discussion in 'macOS' started by NinjaSnowmans, Jul 28, 2010.

  1. NinjaSnowmans macrumors newbie

    Jul 28, 2010
    Ok guys, I'm running Mac OSX Leopard, and I'm trying to run a webclient that uses Java. My Java appears to be up to date and everything, but it will never load. I keep getting error messages, like this one: java.lang.UnsupportedClassVersionError: Bad version number in .class file

    I've tried multiple browsers (Safari, Firefox, Chrome, Opera, Camino, Seamonkey, IE) but nothing is working. Help me out?
  2. svenwillmann macrumors member

    May 6, 2008
    can you give us some more information on this

    what do you mean by “webclient”, I suspect you are talking about an Applet?
    It can be that the “webclient” you are trying to run is compiled with a later version than you are trying to run it in

    can you post the output of the following terminal command:
    ...$ java -version

    can we view the “webclient” eg. do you have an internet address or just more info on it
  3. sgjohnston macrumors newbie

    Dec 14, 2009
    Sounds like either the applet is corrupt, or has been built with Java 1.7, which is not released yet and will not run with Java 1.6 (6.0).


Share This Page