Help with launchd

Discussion in 'Mac Programming' started by durlecs, Aug 21, 2011.

  1. durlecs, Aug 21, 2011
    Last edited: Aug 22, 2011

    durlecs macrumors newbie

    Aug 21, 2011
    I have been trying to get launchd working with rss2email for the last few days with no luck. I think I am close, but no cigar yet. Here is what I have managed so far.

    1) created this plist file, com.macattack.r2e.plist, in ~/Library/LaunchAgents

    <?xml version="1.0" encoding="UTF-8"?>
    <!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "">
    <plist version="1.0">





    2) Created an sh script,, located in ~/rss2email as shown below:

    cd /Users/macattack/rss2email/ ; ./r2e run​

    3) Installed rss2email and made sure it works from running in terminal both "./r2e run" and "./". Both work well and send the feeds to my email address.

    4) I added the rss2email folder to .bash_profile to look like this:

    # Setting PATH for Python 2.7
    # The orginal version is saved in .bash_profile.pysave
    export PATH ​

    5) When I type "echo $PATH" the output is:


    6) When I look in Console, this is the output I get:

    8/22/11 1:01:38 AM com.macattack.r2e[541] I: Processing [2] "index.rss"
    8/22/11 1:01:46 AM com.macattack.r2e[541] Fatal error: could not authenticate with mail server "" as user "email@address"
    8/22/11 1:01:46 AM com.macattack.r2e[541] Check your file to confirm that SMTP_SERVER and other mail server settings are configured properly
    8/22/11 1:01:46 AM[183] (com.macattack.r2e[541]) Exited with exit code: 1​

    Yet, when I run "./r2e run" or "./", it emails just fine and there is no problem with the smtp server authenticating. I have come a long way and learned a lot. I feel like I am close but I just can't seem to get it working correctly. I am a complete noob at this and I have just been piecing together what I can find on the forums. I was not able to get the r2e to run directly in the plist file. I tried many different ways. That is why I created the script file. Any help will be greatly appreciated. Thanks in advance.
  2. durlecs thread starter macrumors newbie

    Aug 21, 2011
    Maybe a Python issue?

    I have been working on this more and searching around on the net and I think it may be a Python version problem. I had to install Python 2.7 in order to get the rss2email to work properly from the working directory. So, I am wondering how to specify that the r2e script uses Python 2.7 instead of the 2.6, 2.5, or 2.3 that I found on my system. I am running SL 10.6.8 if that helps. I tried adding:


    However, this did not help and it still will not authenticate the email. I really need to get this working as I have spent way too much time on it already. I am about ready to install Ubuntu virtually and just run crontab. Crontab seems much easier. I set it up on another machine and it ran fine under Ubuntu 11.04. I just don't like being defeated by something that seems like should be simple.
  3. durlecs thread starter macrumors newbie

    Aug 21, 2011
    Got it!

    It was a path issue for Python. I added /usr/local/bin to the PATH and it works! Maybe this will help someone else that runs into this problem.
  4. LostSoul80 macrumors 68020


    Jan 25, 2009
    Glad you solved the problem. Mark the thread as "Resolved", please.
  5. n8felton macrumors newbie

    Jun 7, 2010
    I just want to add my 2 cents in here quick. All I did was open the "r2e" script that comes with the 2.71 version of rss2email and added the following line to it and all is well.

    cd "$(dirname "$0")"

Share This Page