Help with Loading OS and SSD

Discussion in 'MacBook Pro' started by Captshwa, Jan 29, 2014.

  1. Captshwa macrumors newbie

    Joined:
    Jan 29, 2014
    #1
    Ok, if anyone has any help, I am at my wits end!

    I have a 13.3 inch mid 2010 MacBook Pro.

    I recently installed a SSD in it (it is a compatible one), the drive would not partition, I tried everything, and even took it to the Apple store and a computer store nearby. They couldn't help.

    I finally purchased an external enclosure, and for whatever reason, I was able to partition it when it was in the enclosure, I then did a back up from my Time Machine onto it, and it worked fine.

    When I put it into the MBP internally, it won't boot off the SSD. I have switched back and forth so many times, and the result is the same. If it is connected via USB to the external enclosure, it boots fine and runs great...but when internal, won't do anything.

    Even tried doing the recovery boot, but it won't do that.

    to make matters worse, after reading some threads here, I decided to try something.

    I was going to partition the SSD again, then restore my original MBP drive to the time machine backup, then do an image copy over to the SSD.

    However, it started the process, then gave me an error message, which in turn left my original MBP hard drive erased!

    The loss of information is no problem as it is all backed up on external storage.

    But I am stuck now with a pretty useless (but pricy!) computer.

    Currently I have the new SSD that works but only when connected externally.

    and the original HD that is internal, and is not completely erased, and for some reason will not take the time machine backup, and it also won't take the restore from internet or disk OS!

    I ran the internet restore for Mavericks, and it downloaded, said it was installing, took 45 minutes then upon finishing simply went back to the screen with the options to -restore from time machine, -reinstall mavericks, -disk utility etc.

    I am at a loss!


    any suggestions?

    I have reset PRAM, and have tried going back to snow leopard (won't even let me select the drive for that)
     
  2. disasterdrone macrumors 6502

    Joined:
    Aug 31, 2013
    #2
    So - to be clear - what happens if you put the ssd in the enclosure, and format it, then install the os on it? Can you boot from it when it is in the external enclosure?
     
  3. DeltaMac macrumors 604

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #3
    OP did, in fact, say that an external install and boot does work.

    Which exact SSD brand and model do you have?
    There are a few that are not compatible, particularly if your SSD is SATA 3, not SATA 2.
    Your MBPro has a SATA 2 bus.

    The fact that you CAN use and boot from the SSD from an external case, but not when installed internally, is not unusual.
    Why does your SSD work in the external case? The enclosure drive interface may be more tolerant of different SSDs, and the SSD just doesn't work well on the internal bus in your older MBPro.
    I suspect that you have an SSD that is a 6 Gbps model, and not happy with clocking down to the slower 3 Gbps on your internal SATA bus. Some SSDs may have a firmware update that will help your SSD work.
    But, you may also want to return your SSD, and change to an SSD that will work better on your 3 Gbps drive bus.
     
  4. disasterdrone macrumors 6502

    Joined:
    Aug 31, 2013
    #4
    Sorry - completely missed that - I agree with your diagnosis.
     
  5. heisenberg123 macrumors 603

    heisenberg123

    Joined:
    Oct 31, 2010
    Location:
    Hamilton, Ontario
    #5
    Make sure the sata cable inside did not come lose on the end that connects to the logic board
     
  6. Captshwa thread starter macrumors newbie

    Joined:
    Jan 29, 2014
    #6
    Hello,

    Thanks for the input.

    The drive is a Crucial M500 480 GB, I used their specific drive selection tool
    Crucial M500 480GB 2.5-inch Internal SSD


    It doesn't say if it is SATA 3 or 2, but it does say 6 Gb/s (but 3 Gb/s compatible)

    the cable inside is undamaged, and attached.

    I will call Crucial again, but if the item says compatible with 3 Gb/s, wouldn't that be sufficient?


    I think I bit off more than I can chew here.
     
  7. heisenberg123 macrumors 603

    heisenberg123

    Joined:
    Oct 31, 2010
    Location:
    Hamilton, Ontario
    #7
    yes that should mean it will work even if you machine is SATA II

    SATA III = 6.0gbps
    SATA II = 3.0gbps
     
  8. Mike Boreham macrumors 65816

    Joined:
    Aug 10, 2006
    Location:
    UK
    #8
    Did you format it with a GUID partition table?

    Check what Partition table type is in Disk Utility.
     
  9. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #9
    Even though it looks okay, those cables do go bad. Perhaps the jostling of the drive swap pushed it over the edge.

    Just so I am clear, when you put the old hard drive back in and boot to recovery off the Time Machine disk, you cannot access/format the old drive either? If that is the case, that really does point to a bad cable.

    SATAIII is backwards compatible with SATAII, so this should not be an issue.

    If he had this wrong, it would not boot from the external enclosure like it does.
     
  10. Captshwa thread starter macrumors newbie

    Joined:
    Jan 29, 2014
    #10
    Thanks again, one more visit to the Apple store, then I maybe going back to my old PC ways!


    It is partitioned GUID

    and I will ask about the cable, but if the cable was damaged, wouldn't it not even recognize the drive?

    originally the problem was just with the SSD, it wouldn't boot internally, and I considered the cable, however when I put the original drive back in, everything ran as it used to (which signaled to me that the cable was fine?)

    it was only when I tried to restore my old drive to a point in the past that everything messed up with my original drive too.
     
  11. ElectronGuru macrumors 65816

    Joined:
    Sep 5, 2013
    Location:
    Oregon, USA
    #11
    I put this exact drive into my 2010 MPB 13 2.4 a few weeks ago. Install went perfect, operation is perfect. Afaik, they only have one model. I bought their USB connector and built the drive before installation.

    Btw, I did my standard clean install:
    http://forums.macrumors.com/showthread.php?p=18693951#post18693951

    If that doesn't work, request an RMA
     
  12. Captshwa thread starter macrumors newbie

    Joined:
    Jan 29, 2014
    #12
    Thanks Electron guru...

    if I get the original drive on my MBP fixed tomorrow, I will attempt your way, maybe by their version of the USB connector, although I wouldn't think that the actual enclosure would make a difference?

    did the drive come with any software for install?

    thanks again, everything helps, this is so frustrating, and really turning me off Mac.
     
  13. Astroboy907 macrumors 65816

    Astroboy907

    Joined:
    May 6, 2012
    Location:
    Spaceball One
    #13
    I believe the 2010 13" model is notorious for SATA cable failures. I'd say go buy one cheap and try it out.
     
  14. ElectronGuru macrumors 65816

    Joined:
    Sep 5, 2013
    Location:
    Oregon, USA
    #14
    The cable comes as part of a kit that includes software, but I never took the disk out of the sleeve. Just hook the bare drive to the MBP with the cable and jump right to the formatting step:

    http://www.crucial.com/store/partspecs.aspx?IMODULE=CTLAPINSTALLAC


    Unless the housing you picked up is itself defective, the type of connection shouldnt matter. usb, fw, this should only effect speed and drive protection.
     
  15. Captshwa thread starter macrumors newbie

    Joined:
    Jan 29, 2014
    #15
    Just want to thank everyone for taking the time to post suggestions.

    after weeks of trying so many things, I shoulda gone with the first thing I read!!

    It seems to be it was exactly that, a problem with the SATA cable.

    I had ruled that out because it seemed to work with the original drive, and even when I started having issues with the original drive, when i finally got at least snow leopard installed externally, it worked with the drive.

    anyway, went to the apple store, and they couldn't do it either, suggested the cable, 60 bucks later, it works perfectly.

    So I guess maybe the cable worked somewhat, but had faults somewhere along it.

    headache finished!

    thanks again.

    now to see if the SSD is worth the switch, unfortunately some of the excitement is gone after all this!
     

Share This Page