Help with lockscreen background !!!

Discussion in 'Jailbreaks and iOS Hacks' started by giggs11x, Jul 15, 2009.

  1. giggs11x macrumors newbie

    Joined:
    Jul 15, 2009
    #1
    Currently I'm using some lockscreen feature: Multibar Lockscreen from Cydia.
    Everything was fine except that there is no background image shown.

    I've follow through some guide to delete off the lockbackground image file in /var/mobile/library but it still doesn't works.

    Anyone has any idea where has it gone wrong? :(

    Thanks in advance.
     
  2. Speedracer04 macrumors 6502a

    Speedracer04

    Joined:
    Sep 8, 2006
    Location:
    Michigan
    #2
    You shouldnt really delete anything,

    The new wallpaper you want should just go into the mulibar lockscreen theme folder /Library/Themes/Multibar folder

    Put the wallpaper you want in that folder and name it Wallpaper.png

    Then when you activate the theme in winterboard it will use that picture as your wallpaper
     
  3. giggs11x thread starter macrumors newbie

    Joined:
    Jul 15, 2009
    #3
    i've paste the Wallpaper.png in and its still not coming out.
    Lockscreen is still black.

    Whether or not i check the User LockBackground from winterboard its still the same :(
     
  4. billchase2 macrumors 68000

    billchase2

    Joined:
    Feb 28, 2006
    Location:
    Ann Arbor
    #4
    Move LockBackground higher on the list within Winterboard. Perhaps you have another theme activated (that's higher up on the list) that is overwriting it.
     
  5. giggs11x thread starter macrumors newbie

    Joined:
    Jul 15, 2009
    #5
    another application i used is the StatusNotifier. But i could not find its path to replace the image... is that the possible cause?
     
  6. Speedracer04 macrumors 6502a

    Speedracer04

    Joined:
    Sep 8, 2006
    Location:
    Michigan
    #6
    No, status notifier should not cause an issue.

    Ya, I have no idea...is the wallpaper on the lockscreen called Wallpaper.png anyone? I know it is for the springboard but I forget if its differnt for the lock screen background.

    Try renaming it to Lockbackground.png or LockBackgroud.png For some reason those sound familiar
     
  7. giggs11x thread starter macrumors newbie

    Joined:
    Jul 15, 2009
    #7
    i think it is LockBackground... but still the same though.. sigh
     
  8. TechJunky macrumors regular

    Joined:
    Jul 25, 2008
    #8
    Replacing wallpapers from the phone is a known bug with MBL. The only way to get it is to place a pic in the MBL folder and name it "LockBackground.png" HTH.
     
  9. giggs11x thread starter macrumors newbie

    Joined:
    Jul 15, 2009
    #9
    i've alrdy done it... its black still.. so its a known bug? then i give up alrdy :mad:
     
  10. Speedracer04 macrumors 6502a

    Speedracer04

    Joined:
    Sep 8, 2006
    Location:
    Michigan
    #10
    I have a wallpaper on my lockscreen no problem...idk
     
  11. giggs11x thread starter macrumors newbie

    Joined:
    Jul 15, 2009
  12. miggitymac macrumors 6502a

    miggitymac

    Joined:
    Jan 7, 2009
    #12
    SSH into your phone....rename the picture you want as "LockBackground.png" (copy exactly).

    Then drop that .png file into your theme's main folder.

    Should work. If there's another file called LockBackground.html or something in the theme's main folder, make a backup and delete it.
     
  13. giggs11x thread starter macrumors newbie

    Joined:
    Jul 15, 2009
    #13
    would try it out tonight when i have the tool.. hope it works :)
     
  14. toconeal macrumors newbie

    Joined:
    Apr 19, 2009
    #14
    I seem to be having the same trouble. I have tried everything here and more. I have restored to factory and re-JB. Still nothing. I have changed all the theme png's. I still can not get a lock Backgound...
     
  15. TechJunky macrumors regular

    Joined:
    Jul 25, 2008
    #15
    What version of multibar lockscreen are you using?

    You have to name the pic you want to use "LockBackground.png" (don't forget caps) and place it inside the multibar lockscreen folder. Then make sure you have "use lockbackground.png" set to "true" in the settings.js file.
     
  16. scottuf macrumors 6502

    Joined:
    Feb 2, 2009
    Location:
    NPB, FL
    #16
    not currently using MultiBar Lockscreen, but i have a background showing. i have both the LockBackground.html and LockBackground.png in the theme folder. make sure you have the png in there and there isn't any wording in the html that would conflict with or turn off the png as the background.

    pm me and i can email you my files if you think it would help.
     

Share This Page