Help with MagSafe connector

Discussion in 'MacBook Pro' started by Sdahe, Feb 19, 2010.

  1. Sdahe macrumors 68000

    Sdahe

    Joined:
    Oct 26, 2007
    Location:
    San Juan, PR
    #1
    Hello..

    Today I connected my macbook pro to my LED Cinema Display and the MagSafe connector's light was blinking like a hard disk's status light. Is this normal?... it's blinking rapidly like when the light of an external HD is showing the disk is in use. Something like that.

    I just checked the battery status in iStats and it's giving me a 91% healthe.. :eek:. How could that be if this mac is 6 months old.

    battery.png
     
  2. m85476585 macrumors 65816

    Joined:
    Feb 26, 2008
    #2
    The battery health is normal. I don't know what the flashing magsafe light means. Make sure your magsafe connector is clean and free of metal particles (the connector on the computer is the magnetic part that may pick up metal).
     
  3. Sdahe thread starter macrumors 68000

    Sdahe

    Joined:
    Oct 26, 2007
    Location:
    San Juan, PR
    #3
    Thanks, is it OK to clean it with alcohol?
     
  4. cloroxbleach4 macrumors 6502a

    cloroxbleach4

    Joined:
    Dec 28, 2007
    Location:
    Oklahoma
  5. m85476585 macrumors 65816

    Joined:
    Feb 26, 2008
    #5
    Be careful cleaning it with alcohol. Although it is probably safe, you don't want to get any inside the port or the connector. Compressed air or a dry microfiber cloth should work.

    If cleaning it doesn't fix the problem, there is probably a problem with the magsafe or the computer, and you should take it to Apple if it is under warranty.
     
  6. Sdahe thread starter macrumors 68000

    Sdahe

    Joined:
    Oct 26, 2007
    Location:
    San Juan, PR
    #6
    I will clean it and see what happens... thanks guys. I will let you know
     
  7. Jaro65 macrumors 68040

    Jaro65

    Joined:
    Mar 27, 2009
    Location:
    Seattle, WA
    #7
    Just unplug it first if you are going to clean it up with any liquid. :)
     
  8. Sdahe thread starter macrumors 68000

    Sdahe

    Joined:
    Oct 26, 2007
    Location:
    San Juan, PR
    #8
    OK, this is what's going on. If I connect the magSafe and is chargin the MBP it turns the amber light OK... but when it finishes the charging cycle and the light turns yellow it starts to blink.
     
  9. Sdahe thread starter macrumors 68000

    Sdahe

    Joined:
    Oct 26, 2007
    Location:
    San Juan, PR
    #9
    Well, I took the monitor to an Apple service center and they don't know or haven't seen the problem with the magsafe.

    Anyone in this forum has the same problem?
     
  10. Eddyisgreat macrumors 601

    Joined:
    Oct 24, 2007
    #10
    Sound like an issue with the data (center) pin. Have you tried a different MagSafe adapter on the mbp?
     
  11. Gonzo3333 macrumors 6502a

    Gonzo3333

    Joined:
    Mar 30, 2009
    Location:
    Chicago, IL
    #11
    That is weird. The magsafe connector on my ACD is either amber or green and it never flashes.
     
  12. puma1552 macrumors 601

    Joined:
    Nov 20, 2008
    #12
    In the last few weeks I've noticed that the magsafe adapter on my 24 inch LED ACD has a tendency not to light up and not to charge my laptop when connected; the fact it's connected registers with the computer and coconut battery, but if the battery is less than 95% the menu bar shows it's connected but "not charging", and the magsafe LED is off. Basically I'm finding my magsafe on the ACD to be intermittently failing--but if I use the Macbook Pro charger, no problems.
     

Share This Page