Help with Powerbook Adapter/Battery Problem

Discussion in 'Macintosh Computers' started by bostongeek, Mar 2, 2005.

  1. bostongeek macrumors newbie

    Mar 2, 2005
    First off, let me say that this is my first post. I searched this forum (as well as Apple Support online) and haven't found a resolution to the problem). This is a g4 PowerBook 1.5GHz bought back in August/September 2004.

    Yesterday, I noticed that when plugging in the AC power to the powerbook, the light (green or amber) was not lighting up. I also noticed that the battery indicator shows it as being plugged in. It also shows that the battery is not charging (it is stuck on 5%). I tried shutting down and restarting the computer. I also tried resetting the power manager. And, I have plugged it into several outlets/power-strips. Neither of these have helped.

    I would expect the battery to last longer than this, but since this is my first Mac, I have no prior experience to base this on (aside from my experience in the PC world... my significantly older Toshiba laptop still charges fine).

    Anyone have any experience with this problem, or any suggestions. I may end up taking it to my local Apple Store this weekend, but would rather not make the trip. Any help is GREATLY appreciated.

  2. rogerw macrumors 6502

    Mar 13, 2004
    west sussex UK
    i ad this on an ibook and it turned out to be the charger

Share This Page