Help with printing via airport extreme.

Discussion in 'Mac Basics and Help' started by JoeJoe, Dec 22, 2006.

  1. JoeJoe macrumors member

    Oct 8, 2006

    I did a search and can't find what I need.

    I just purchased a Canon PIXMA MP530 and download the drivers. I can print fine when it is hooked directly to my ibook via usb. I can even print from my powerbook as it recognizes the printer through my network(bonjour?) when it's plugged into my ibook usb.

    Anyway......I tried plugging the USB into the USB slot on my airport extreme instead of my ibook, thinking that I could then print wirelessly from both machines. Doesn't work.

    In fact, my entire wireless network goes on the fritz every time I plug in the USB into the airport extreme and I end up re-booting.

    Bottom line. Shouldn't I be able to plug the printer into the USB on the extreme and print from either my ibook or powerbook?

    Both are running 10.4.8.
    Apple base station V5.6.

    Thanks everyone.

    PS. I also have an airport express that I stream music to if that matters.

    edit: One other thing. Whenever I plug the usb into the AE and try to configure via airport admin utility I just get the beach ball. I've tried turning everything off but to no avail.
  2. thedude110 macrumors 68020


    Jun 13, 2005
    Yes, you should be able to plug the printer into the USB port on the AE and print wirelessly care free. I do all the time.

    I don't have a good answer as to what's going wrong, but I can link you to this common problem troubleshooting page.

    Am curious if this problem occurs if you plug into the AE while the AE is powered off (after you turn it back on, of course)?
  3. mad jew Moderator emeritus

    mad jew

    Apr 3, 2004
    Adelaide, Australia
    Are you plugging it in directly or are you using that hub you mentioned? :)
  4. JoeJoe thread starter macrumors member

    Oct 8, 2006
    A little progress.

    Well, a little progress.

    If I shut everything down, plug in the USB into the AE and then power up I get to "keep" my internet connection.

    Still no luck recognizing the printer though.

    I went to configure in the admin utility and it doesn't even "see" the new printer.

    Again, this is plugged right into the USB port on the AE.

    I'll keep trying, and thanks!

Share This Page