help with safari

Discussion in 'Mac Apps and Mac App Store' started by pmtm2, Jan 10, 2010.

  1. pmtm2 macrumors member

    Joined:
    Dec 1, 2009
    #1
    i accidently moved safari and i photo to the trash dont ask stupid move but i got them back from the trash.anyway now when i open my harddrive there are safari and a i photo icon there. they where not there before you had to open the apps folder.when i try to drag them to the folder it says it is coping file,but if i delete the icon it says my safari was moved to trash move it back blah blah blah.my ? is this how do i get rid of the icons and get them back in the apps folder.
     
  2. Gregg2 macrumors 603

    Joined:
    May 22, 2008
    Location:
    Milwaukee, WI
    #2
    Let's see if I understand...

    You have Safari and iPhoto icons both on your Desktop and in your Applications folder. Is that right?

    Do any of them have little curved black arrows at the lower left corner? I doubt it from what you describe, but thought I'd ask anyway. That would be an alias of the application.

    When you move the icons to the Applications Folder, are you then stopping the copying in mid-stream?

    Can you actually launch each program from the icons on the Desktop? And also the icons in the Applications Folder?

    If yes to both locations, then just let the copy proceed.
     
  3. pmtm2 thread starter macrumors member

    Joined:
    Dec 1, 2009
    #3
    i am letting the copy complete no arrows the icons are on the dock,in the harddrive as soon as you open it and they are in the apps folder.you can launch from all 3.i just want the icons thats are appearing when you very first open the harddrive icon to be gone. i want to have to open the apps folder to see them.
     
  4. Gregg2 macrumors 603

    Joined:
    May 22, 2008
    Location:
    Milwaukee, WI
    #4
    Ok. You didn't ever identify your OS version. I have 10.5.8 so this is what I would try...

    com.apple.desktop.plist & com.apple.finder.plist

    One at a time, with the above files, found in Users/MyUserName/Library/Preferences, move plist file to Desktop.
    Restart. This will create a new plist file in Preferences, set to defaults.
    Try to delete those icons.
    Fixed? Then trash the plist file on your Desktop.

    Neither one was the culprit?
    Then you could move the plist files back to Preferences. This will restore any changes you made to those preferences.

    Next: Log in under a different User Account
    Try to delete the files.
    What happened?
     
  5. pmtm2 thread starter macrumors member

    Joined:
    Dec 1, 2009

Share This Page