Help with SAM on 3Gs with new bootrom

Discussion in 'Jailbreaks and iOS Hacks' started by machasm, Dec 21, 2010.

  1. machasm macrumors member

    Joined:
    Dec 21, 2010
    #1
    Hi all,
    first post and first Iphone :)
    I have an iphone 3Gs which I have succesfully jailbroken using redsnow and IOS4.1 and had to update to baseband 6.15 as I have the newer ROM. (Didn't want to go to 4.2.1 as its still a tethered JB).
    I then installed SAM and succesfully de-activated the phone.
    However, I am unable to get itunes to activate it. I keep getting a "wrong sim card" message from itunes.
    I am afraid that I do not know who the original carrier is for this phone.
    I do have the model number however MC637B/A as well as the serial number and IMEI number.
    It is a UK phone and I have been through most of the options when choosing "Method" in SAM as autodetect did not work either.
    So anyone got any ideas?
    Any way of finding out which carrier it was originally with?
    Or does SAM not work with this version of bootrom?
    Thanks.
    Mac.
     
  2. MaxBurn macrumors 65816

    MaxBurn

    Joined:
    Nov 25, 2010
    #2
    I think it may take some trial and error if you don't know which carrier it is locked to. I don't know a way to tell but there can't be that many to try?
     
  3. machasm thread starter macrumors member

    Joined:
    Dec 21, 2010
    #3
    Thanks for the quick reply.
    I think that I have been through every single UK carrier listed.
    All gave me the same problem.
    So either it doesn't work with this version of bootrom or I still haven't found the correct carrier.
    Any more clues anybody?
    Cheers.
    Mac.
     
  4. machasm thread starter macrumors member

    Joined:
    Dec 21, 2010
    #4
    Just a cheeky bump.
    Anyone got any other ideas on this?
     
  5. BillyBobBongo macrumors 68020

    BillyBobBongo

    Joined:
    Jun 21, 2007
    Location:
    On The Interweb Thingy!
    #5
    I had this too over, with my Dutch provider.

    I shuffled between the Auto Detect option and manually choosing which carrier/country the SIM was from, I also rebooted the phone during the process a couple of times...and then during another attempt, for no apparent reason, it activated.

    Mine activated whilst on the Auto Detect setting.
     
  6. machasm thread starter macrumors member

    Joined:
    Dec 21, 2010
    #6
    Hmmm.....
    Thanks for that. After about an hour of fiddling I finally gave up and reverted to hacktivation through redsnow.
    Still would like to be able to get it to work through SAM though.
    Perhaps this might be fixed in a later release?
    Mac.
     

Share This Page