Help with Samsung CLP-315W (Can't Get it to Connect to Wireless Network)

Discussion in 'Mac Accessories' started by Terry W, Oct 14, 2009.

  1. Terry W macrumors member

    Apr 20, 2007
    Having a problem connecting my Samsung CLP-315W to my wireless network. It works just fine if connected directly to my computer by USB cable, but that kind of defeats the purpose of buying a wirelessly-enabled printer!

    I was able to print out a Network Configuration Report which indicates an IP Address, MAC Address, Subnet Mask, etc. It even says that the thing is connected to a network called "airportthru" but I have no idea what that is either... I'm an absolute networking zero for the record.

    I can't access the SyncThru Web Service (as noted in the instructions) because when I put the IP address into my browser - both Safari and Firefox - I get an error (can't open the page because the server can't be found).

    Tried adding the printer in the SetIP aplet and it says it can't connect and to reconfirm the MAC address, which I did and is correct.

    Any help would be greatly appreciated.
  2. skorpien macrumors 68020

    Jan 14, 2008
    Sounds to me like it's connected to a network other than yours. Is there any way you could select your network from a list of available networks and input the password?
  3. Terry W thread starter macrumors member

    Apr 20, 2007
    Thanks for the quick reply. Unfortunately, I can't connect to the printer via my browser or through Samsung's SyncThru web server, for unknown reasons. According to the instructions, were I to connect to the printer itself, I would be able to change what network it is connecting to. Therein lies the issue... :(
  4. skorpien macrumors 68020

    Jan 14, 2008
    Wow, that is one doozy of a setup! Just reading the instruction manual has made me cringe in fear :( haha. It seems you need to connect your printer to the network via the crossover cable supplied with the printer in order to set it up initially. And you also need to disable the firewall apparently. I'm really inexperienced with this printer so I'm grasping at straws. I assume you already have the manual, but here's a link to the online version. Sorry I couldn't be of much help.
  5. Euph macrumors newbie

    Jan 22, 2010
    CLP-315W connected to wireless network step-by-step

    Okay. I got this to work. The information is in the manual, but it's only clear after you do it.

    I have an Airport Express base station and a MBP 13" unibody.

    1) Install the driver. I downloaded the latest from Samsung, but you can also use the cd that comes with the printer. You need the "SetIP" applet, which is in the setIP folder on the CD or in downloads (or spotlight to it) to continue.

    2) connect the crossover ethernet cable that came with the printer between the printer and the computer.

    3) TURN OFF YOUR AIRPORT ON THE MAC or you won't be able to connect to the printer through the cable.

    3) First, using the network settings on the mac, determine the COMPUTER's IP address and settings. Here were mine:


    start the "set IP" applet and change the ip address of the printer by pressing the refresh button (circular arrows) and then pressing the button that looks like a gear.

    Type in the MAC address of your printer that came up after you pressed the refresh button.

    Change the IP to be the same as the computer, except with the last number changed. I made mine The subnet should be the same as the computer above (mine is, and the default gateway is the computer's address, mine is as above. press apply and the settings should change. Check the settings have changed by pressing refresh in setIP.

    4) Okay, now you can change the settings on your printer by starting a new tab on your browser and typing the URL. (or whatever your printer's new address is). the syncthru application should come up.

    on the top tabs choose "network settings", then "TCP/IP" on the left and change the "IP address assignment method" to DHCP. scroll down and press Apply.

    Now go to "wireless" on the left, scroll down and press next to start the wizard. It should see your wireless network. Just click on it and go through the menus to put in your password etc. Make sure to hit apply, and your done setting it up.

    5) Now disconnect the cable and the printer should connect itself to the wireless network. You can turn your computer's wireless connection back on now and use setIP to find the printer. It should have a new IP address. You can also hold down the button on the printer for 5 seconds to print the configuration to confirm that it's on the network.

    Samsung's manual is really opaque. I hope this clears it up.
  6. NigelFrobisher macrumors newbie

    Feb 6, 2010

    This was a great help because i was at a loss. Worked perfectly. :)
  7. matthoffman7 macrumors newbie

    May 10, 2010
    Can't launch Syncthru application

    Euph - thanks for the brilliant post, what a great help.

    I've done everything as you said, but I'm not getting the syncthru application to launch using the new printer IP address as the URL. It reads "Safari can't open the page because the server at is not responding."

    I've tried reassigning two different IP addresses to the printer. Also tried with and without the ethernet cable connected between the MBP and the printer.

    Please help,
  8. skorpien macrumors 68020

    Jan 14, 2008
    #8 Are you using an Apple AirPort router? If so, the default IP range is Did you try
  9. ourobora macrumors newbie

    Dec 18, 2010
    I have struggled with a similar problem for a few days now and finally found the solution. I have a dlink DIR 655 router, which was using an automatically generated PSK (shared key). After checking my router's logs, I noticed that my printer's MAC address kept being deauthenticated.

    The problem was this: the key generated by the router was 64 characters long, while my Samsung CLP 315W wireless setup allowed me to only enter 63 characters. After removing the last character in my PSK and rebooting my router, I was able to connect the router wirelessly to my network.
  10. fullofbull macrumors newbie

    May 5, 2011
    where's wireless

    Euph - thanks for your post - I have the same problem

    However, I block at your point number 4 because after having changed the IP adress assignment method to DHCP and pressing apply, I cannot find the "wireless" on the left that you speak about!

    Looking forward to your reply

    Thanks in advance
  11. Benbikeman macrumors 6502a


    May 17, 2011
    London, England
    Thanks for that - a great help. Using the info here, I was able to do a slightly simpler install:

    1. I skipped this, as the Mac sorted out the driver automatically.

    2+3. Instead, I connected the printer to one of the three Ethernet ports on the Time Capsule using a standard Ethernet cable.

    Then in step 4, the Wizard didn't work so I used Custom.

Share This Page