Help with sendmail: fatal: unable to use my own hostname

Discussion in 'macOS' started by brisak, Sep 2, 2009.

  1. brisak macrumors newbie

    Joined:
    Sep 2, 2009
    #1
    So I can't get into the intro screen, restarted using Install DVD, in terminal did:
    sudo chmod -R 777 / (as read after research)

    got the response:

    sudo: can't open /private/etc/sudoers: Permission denied
    :/ root# sendmail: warning: valid_hostname: empty hostname
    sendmail: fatal: unable to use my own hostname

    How can I fix this? I can't log in, it keeps on the blue screen with the spinning wheel. Did a research and found an similar unanswered thread (on page 2 of the thread, last post).

    Thank you for any help!
     
  2. brisak thread starter macrumors newbie

    Joined:
    Sep 2, 2009
    #2
    I decided to to an archive and Install. It didn't do it!! Said that couldn't find something on the system and told me to call the manufacture. What???? I've never seen this!

    Please help!
     
  3. brisak thread starter macrumors newbie

    Joined:
    Sep 2, 2009
    #3
    Posting pictures of other tries

    through anothe forum I've learned I was wrongly using sudo. So that's what I did, on single user mode:

    /sbin/fsck -fy
    (return)
    waited for the results and then:
    /sbin/moun -uw /
    (return)
    waited for results
    chmod -R 777 /
    return

    after that I restarted and....voila! hahaha. Oh happy day!!!!:)
     
  4. theflurr macrumors newbie

    Joined:
    Apr 13, 2013
    #4
    i tried this and now all i get is a grey screen with logo, wont go any further nor will it boot any other way ie=from cd drive. help!!!
     

Share This Page