Help with shortcut icons - PNG always displays?

Discussion in 'macOS' started by plymman, Feb 22, 2011.

  1. plymman macrumors member

    Joined:
    May 9, 2010
    #1
    Can anyone help aas I've been tearing my hair out with this one. I have a bunch of web shortcuts on my desktop and I want to add the icon to the shortcut. Simple right? I open 'Get Info' copy my icon over the default and it applies it but it never shows it. It only shows the default PNG icon (with the pictures and the camera) This also happens whenever I try to change any folder icons. Its obviously changing it and applying it but seems incapable of displaying it.

    I know this should work, I know it should be this simple, so what's happening and why can't I get them to display correctly? All I want is a nice neat desktop!
     
  2. smirk macrumors 6502a

    smirk

    Joined:
    Jul 18, 2002
    Location:
    Orange County, CA
    #2
    That's really strange. I just tried it on my 10.6 system and it worked perfectly. So you're saying that you copy your PNG image to the clipboard, Get Info on the web alias, select the icon image in the Get Info window, and paste the PNG into it... and what happens? The Get Info window reflects the new icon but the Desktop doesn't?

    This is kind of a weak suggestion but have you tried doing a permission repair in Disk Utility?
     
  3. plymman thread starter macrumors member

    Joined:
    May 9, 2010
    #3
    Well sometimes the get info windows shows the new icon when I've copied it over, sometimes it doesn't, either the shortcut, folder etc.. I have just changed only ever shows the png icon.

    Something's screwed somewhere but I have no idea what. I'm pretty new to osx so havent tried a permissions restore yet, but if it's easy and low risk I'll give it a go. It might seem like a small issue but having a dozen or so desktop shortcuts and folders with the same icon is no joke!
     
  4. smirk macrumors 6502a

    smirk

    Joined:
    Jul 18, 2002
    Location:
    Orange County, CA
    #4
    It is very easy and low risk.

    http://guides.macrumors.com/Repairing_Permissions

    I kind of doubt that it will resolve your problem, but you never know. Something is preventing the file from adopting a new icon, it could be a strange issue where you don't have permission to replace the icon.

    Are web shortcuts the only items giving you trouble? Is it always the same icons or will an icon refuse to change one day, but then it will change on another day?
     
  5. plymman thread starter macrumors member

    Joined:
    May 9, 2010
    #5
    Not just shortcuts, it also happens with folders. I can download an icon pack, copy them to my my home folders and voila! All just display the png icon.....
     
  6. plymman thread starter macrumors member

    Joined:
    May 9, 2010
    #6
    I've repaired permissions and no joy. Even when I try to change the icon to a jpg it still shows the PNG icon.......I'm at a loss....
     
  7. ergdegdeg Moderator emeritus

    ergdegdeg

    Joined:
    Oct 13, 2007
  8. plymman thread starter macrumors member

    Joined:
    May 9, 2010
    #8
    Thanks for that, just tried it. Same result I'm afraid, still showing the PNG icon.
     
  9. ergdegdeg Moderator emeritus

    ergdegdeg

    Joined:
    Oct 13, 2007
    #9
    Hmm.. What are you actually doing when copying the icon? "Get Info" on both the icon and the item that is supposed to get the new icon, then click on the top left image of the icon in the "Get Info" window, copy and paste onto the top left image of the other item?
     
  10. smirk macrumors 6502a

    smirk

    Joined:
    Jul 18, 2002
    Location:
    Orange County, CA
    #10
    Strange. What happens if you try to change the icon of a file in a different folder, not one on your desktop?

    For troubleshooting, you could try this in another user account to see if it still happens. If you don't have another user account you could create one, test it, then delete the user account. I'm wondering if there's something wrong with the OS in general or if it's just a setting on your account.
     
  11. plymman thread starter macrumors member

    Joined:
    May 9, 2010
    #11
    Yep, exactly that. Ill create a new account and try then report back
     

Share This Page