Help with spotlight search, Please!!!!

Discussion in 'iOS 10' started by JDabney24, Oct 5, 2016.

  1. JDabney24 macrumors regular

    Joined:
    Sep 24, 2014
    #1
    This is my third or fourth attempt to get help in this forum among others. I have been experiencing a weird phenomenon on my iphone since spotlight search has been introduced and for some reason has carried over to newer updates to the software and even has carried over to newer iphones. I cannot for the life of me figure out why my spotlight internet search results fail to work while being on a cellular connection. It just refuses to work. I've tried everything I can think of. I've rebooted my phone (soft and hard resets), I have reset network settings, reset all settings, reset and restored iphone, restored iphone from icloud backup, itunes backup, even restored phone as new and am still having the issue. If I reboot my phone or restore it in anyway, spotlight internet search results will work for a couple hours (at minimum) or a couple days (at max) before not working again. I just don't get it. It's maddening. It's such a practical feature on the go when I need to look up movie or venue info on the fly. It works as soon as I'm connected to wifi and without a problem, but as soon as I am on cellular connection (3g or LTE) it stops working. I've attempted to call apple and they will be getting back to me, but their initial response was out of confusion. Is there something I'm not doing or something I'm missing? Please help if you can. I'm using an iPhone 6s Plus on Sprint. I don't think it's a sprint issue since my friends who have sprint don't have the same issue as I do. Btw, spotlight search works with finding stuff locally on the device.
     
  2. C DM macrumors Sandy Bridge

    Joined:
    Oct 17, 2011
    #2
    So what is an example of something that doesn't' work? And what happens exactly?
     
  3. JDabney24 thread starter macrumors regular

    Joined:
    Sep 24, 2014
    #3
    Here is a previous post of mine on the same issue. Has a screen capture of what I'm talking about.

    http://forums.macrumors.com/threads/spotlight-search-results-well-spotty.1969017/

    If I were to start typing in spotlight search, "movies" for example, it would start to populate the search results with movies that are playing nearby along with showtimes and other relevant info pertaining to the title such as wikipedia results etc. This, however ceases to work on cellular connection for some unknown reason.
     
  4. Armen macrumors 604

    Armen

    Joined:
    Apr 30, 2013
    Location:
    127.0.0.1
    #4
    Have you disabled any location services? The only variable I'm seeing from your brief description is that your search is returning location based results on wifi but not on cellular.
     
  5. JDabney24 thread starter macrumors regular

    Joined:
    Sep 24, 2014
    #5
    All my location settings under privacy are on.
     
  6. Armen macrumors 604

    Armen

    Joined:
    Apr 30, 2013
    Location:
    127.0.0.1
    #6
    So when you are on WiFi you get results but don't on a cellular? have you tried resetting network settings?
     
  7. JDabney24 thread starter macrumors regular

    Joined:
    Sep 24, 2014
    #7
    Yes I have. Along with all settings. I am currently on my iPhone that has been restored as new iPhone. Still nothing.
     
  8. fox1401 macrumors regular

    fox1401

    Joined:
    Sep 8, 2015
    #8
    the spotlight proactive search depends heavily on network quality, so if the connection is not good, you get no result. That's why you only got it working under WIFI.
     
  9. JDabney24 thread starter macrumors regular

    Joined:
    Sep 24, 2014
    #9
    Normally I'd agree with you, but I'm in an area where I get full signal LTE, and fast LTE at that. It's just bizarre...
     
  10. C DM macrumors Sandy Bridge

    Joined:
    Oct 17, 2011
    #10
    Have your friends who have the same carrier (and perhaps the same device) tried it all from the same areas where you tried it?
     
  11. JDabney24 thread starter macrumors regular

    Joined:
    Sep 24, 2014
    #11
    I just tried my friend's iPhone running iOS 10 on sprint and his is working on cellular flawlessly. I really don't understand what is the problem. I am currently using my phone restored as a new iPhone.
     
  12. fox1401 macrumors regular

    fox1401

    Joined:
    Sep 8, 2015
    #12
    Believe it or not, I've been through the same situation, no result under full LTE signal. Everything's fine after a day or two.
     
  13. JDabney24 thread starter macrumors regular

    Joined:
    Sep 24, 2014
    #13
    Once again, rebooted my phone and it's working on cellular connection. I'll post when it stops working again...Thanks for the responses!
     
  14. JDabney24 thread starter macrumors regular

    Joined:
    Sep 24, 2014
    #14
    And...just like that, it'a no longer working on cellular connection again. I think I'll just give up. There isn't a rhyme or reason as to why it stops working. Thanks, everyone for all your help!
     

Share This Page