Help with Terminal

Discussion in 'Mac Basics and Help' started by Mullin, Apr 19, 2012.

  1. Mullin macrumors newbie

    Joined:
    Apr 1, 2012
    #1
    I have a 1TB FreeAgent GoFlex Drive. I wanted to delete some of my backups off of my drive so I dragged them from my drive to my trash on my mac book pro. There were for 4 files in total. I entered the command sudo rm -R . In my terminal and I dragged the files in my terminal. This didn't work like it normally does so now the files are just sitting in my trash. I can't put them back into my drive because the files can't be modified. I tried changing the sharing and permission to read and write, this seemed to work somewhat but it still doesn't ket me delete everything. I'm fairly new to all this so if possible I'd like someone to tell me how to solve this problem.

    Thanks in advance.
     
  2. porcupine8 macrumors 6502a

    Joined:
    Mar 2, 2011
    #2
    I'm a little confused. The terminal is text-only - you can't drag files in it. And you only need to delete files by dragging to the trash & emptying the trash OR rm in the terminal, not both. Did you drag them to the trash first or run the rm command first? What shows now when you run ls?
     
  3. maflynn Moderator

    maflynn

    Staff Member

    Joined:
    May 3, 2009
    Location:
    Boston
    #3
    dragging files or folders to the terminal places the name in the terminal. Its a short cut action instead of typing the file/paths

    ----------

    OP, how are the files sitting in the trash because the rm command deletes the files immediately bypassing the trash?

    Personally, I'd avoid using the terminal and just dragged the files to the trash.

    To summarize, you typed sudo rm -R <some file name>, it didn't work and now you have the files in the trash.

    That really doesn't seem to make sense unless I'm not getting something. Also what's the error you received when you tried rm?
     
  4. Mullin thread starter macrumors newbie

    Joined:
    Apr 1, 2012
    #4
    Thanks everyone for the replies, the problem was solved. When I restarted my mac the files were no longer in my trash. Thanks again.
     

Share This Page