Help with Win XP SP3, Parallels, and Bootcamp

Discussion in 'Windows, Linux & Others on the Mac' started by Enigmafan420, Jul 23, 2008.

  1. Enigmafan420 macrumors 6502a

    Enigmafan420

    Joined:
    Apr 18, 2008
    Location:
    Puget Sound, U.S.A.
    #1
    I have installed XP service pack 3 TWICE on my bootcamp partition. BOTH TIMES, after it installs, there is one more Windows XP critical update and once that is installed, Windows will no longer boot. I get an error that says "Hal.dll is missing or corrupted".

    I have followed Parallels instructions for fixing this issue (repairing XP install)-however, after doing so, Parallels no longer will boot into the BootCamp partition and bootcamp itself will not boot automatically (I must choose to boot to windows, and then manually select the bootcamp partition).

    Has anyone else had this problem? It is driving me nuckin futs, and what a waste of time to reinstall windows TWICE. I will not use SP 3 again until I can figure this issue out. :mad:
     
  2. treader286 macrumors newbie

    Joined:
    Sep 14, 2008
    #2
    Enigmafan:
    I found this on another site. Steps 5 thru 9a fixed the problem for me. If you haven't already solved your problem this should do the trick for you. Like a lot of people (I think) I installed sp3, THEN I discovered there was a problem.
    Here you go:

    0) I have XP on a 'Boot Camp' partition, and not in an image file. If you
    have the VM in an image file, the rest of this won't make any sense at all.

    1) Boot the machine to XP on the Boot Camp partition.

    2) Install Boot Camp 2.1 from Apple. The URL is:
    http://www.apple.com/support/downloa...windowsxp.html
    This is essential *before* installing SP3.

    2a) Reboot.

    3) Install SP3. I downloaded the full install from Microsoft.

    3a) Reboot.

    4) Select your OS X partition as your Startup Disk and

    4a) Reboot.

    5) Once OS X boots and you are logged in, start Parallels, but *DO NOT*
    start the VM!

    6) Open your VM configuration, and select 'Hard Disk -> Advanced'

    7) Click on the "Clear..." button under the "Cleanup Boot Camp partition"
    section. This allows Parallels to 'learn' about the changes made by the SP3
    install.

    8) Start your VM.

    9) Once the VM is started and logged in, *RE-INSTALL* the Parallels Tools!

    9a) Reboot the VM.
     
  3. Enigmafan420 thread starter macrumors 6502a

    Enigmafan420

    Joined:
    Apr 18, 2008
    Location:
    Puget Sound, U.S.A.
    #3
    Wow that is a lot of steps! This DID work for you?

    I am sort of gun-shy on this as I REALLY don't want to reinstall Windows (again). I sure seem to have better things to do with my time!

    Thanks for the info-what kind of errors were you getting? My windows said HAL.DLL was missing or corrupt-but I knew that Windows worked fine prior to the SP-3 install.

    Thanks!

    jack
     
  4. Keleko macrumors 68000

    Joined:
    Mar 26, 2008
    #4
    It isn't really that many steps. Just follow them one by one, and you should be fine. The steps pretty much outline what I did, too, and it worked.

    It may be important to download the full SP3 install instead of getting it through windows update. That's what I ended up doing, and it all worked following the steps below.
     
  5. treader286 macrumors newbie

    Joined:
    Sep 14, 2008
    #5
    Enigmafan, I had already installed SP3, then parallels quit working. Whenever I tried to start it, it gave me the missing or corrupted .dll message and then went into kind of a "boot loop" where it would just get stuck. I could manually boot up to boot camp when starting my machine but parallels would not work. When I found the 10 step fix above I just started at step 5 and went on from there. I never reinstalled anything, not windows, service pack 3, boot camp or parallels. It worked like a charm for me.
    Hope this helps.
     
  6. aethernam macrumors newbie

    Joined:
    Nov 14, 2008
    #6
    Thank you Treader. I confirm what you did worked for me too. Though, you have to give Parallels a couple of minutes when restarting XP so it rebuilds the whole thing.
     
  7. pimentoLoaf macrumors 68000

    pimentoLoaf

    Joined:
    Dec 30, 2001
    Location:
    The SimCity Deli
    #7
    That BC url doesn't work anymore -- it brings up a search page in Apple.
     

Share This Page