Help with wireless network

Discussion in 'Community Discussion' started by glocke12, Sep 23, 2010.

  1. glocke12 macrumors 6502a

    glocke12

    Joined:
    Jan 7, 2008
    #1
    Been having lots of problems with my wireless devices losing their connection to my wireless router.

    I have a cable modem supplied by my ISP, and am using a store bought router, a netgear rangemax Wireless N gigabit router.

    I have an imac, macmini, and MBP that all seem to lose connection from time to time. The network still shows up in the pull down menu, they just seem to drop the connection.
     
  2. theITGuy macrumors 6502a

    theITGuy

    Joined:
    Feb 12, 2009
    Location:
    chasing the ghost in the machine
    #2
    Some basic troubleshooting:

    1) Have you tried a different router?
    2) Have you tried your router w/o any security?
    3) Are all the drivers/firmware updated on the PCs and the router?

    And oh yeah stay away from Netgear in general, Linksys consumer products are better :p

    -J.-
     
  3. miles01110 macrumors Core

    miles01110

    Joined:
    Jul 24, 2006
    Location:
    The Ivory Tower (I'm not coming down)
    #3
    Why? I;ve used Netgear routers for years and have had no more problems with them than I have with Apple, Belkin, or Cisco (who took over Linksys... or something along those lines).
     
  4. glocke12 thread starter macrumors 6502a

    glocke12

    Joined:
    Jan 7, 2008
    #4
    So everything is updated...router firmware, mac software, etc..

    My connection still drops. Never had this problem before. I am guessing it may be the router? Is there anything in the routers settings that could cause this?
     
  5. No1nfoProvided macrumors 6502

    Joined:
    Dec 1, 2009
    #5
    What type of security are you using? I dunno if it's possible, but when it's renewing the key, something could be failing (so try a new type of security, or just leave the network unlocked and block all MAC addresses save for the computers that are connecting to the network)? Just throwing some ideas out there.
     
  6. glocke12 thread starter macrumors 6502a

    glocke12

    Joined:
    Jan 7, 2008
    #6
    I was using WPES (I think), but when I did the updates I left the network wide open..Dont know what a MAC addy is, but Ill try and figure that one out.

    Is there any chance it could be a problem with the modem supplied by my ISP?
     

Share This Page