Help with xCode and Simulator

Discussion in 'iOS Programming' started by trsblader, Jan 18, 2013.

  1. trsblader macrumors 6502

    May 20, 2011
    I haven't played around with iOS or xCode since probably xCode 3.2. I have 4.5.2 now (on 2 different machines) and cannot get the iphone or ipad simulator for ANY ios version (5.0, 5.1, or 6.0 - I have them all downloaded) to start after I build a project and select run. I must be doing something wrong from what I remember doing before, or must have a setting wrong or something very simple and easy to fix.

    I do a new project, and don't change any code, just build and run it. The build succeeds with no issues, and then nothing happens. The simulator never runs. Under "scheme" I have a target simulator chosen (I've tried iPhone and iPad simulators for 5.0, 5.1, and 6.0 and none of them work.)

    If someone could help, that would be appreciated.
  2. KoolStar macrumors demi-god


    Oct 16, 2006
    Im curious if the simulator will even run. Open XCode and select the XCode menu, then select open developer tools and then select iphone simulator, does that open?
  3. PhoneyDeveloper macrumors 68040


    Sep 2, 2008
    Xcode honors the iOS deployment target when running. If you build a new project the default deployment target is probably 6.0 so the earlier Sims are probably not available. You didn't mention it but I assume that you downloaded and installed the older Sims from the Preferences window, Downloads pane. I would expect that the 6.0 Sim should work and should be the only version that shows up in the Schemes popup.
  4. trsblader thread starter macrumors 6502

    May 20, 2011
    Yes I downloaded and installed older versions from preferences and none worked, not even 6.0.

    The simulator WOULD open on it's own if I went to developer menu and chose the simulator.

    I ended up solving the problem by uninstalling xcode. First time I uninstalled on my desktop and deleted everything, then re-installed, the issue was still there but the 2nd time worked. Not sure what the issue ever was but apparently uninstalling a couple times fixed it

Share This Page