Help! Word won't let me save... says disk is full, it isn't

Discussion in 'Mac Apps and Mac App Store' started by polycat33, Jan 31, 2008.

  1. polycat33 macrumors 6502

    Joined:
    Jul 1, 2007
    Location:
    Alexandria, VA
    #1
    I apologize if this question has been asked before, the search function on this message board leaves a lot to be desired.

    I've been working on a file in word for the past hour/hour and a half. At one point I needed to scan something to put in the file, so I opened up Photoshop 7 and used the import option to scan from my all-in-one printer. I forgot to plug the printer into the computer before I went to import, and when the import utility opened it complained with a bunch of error boxes about how the scanner wasn't attached. Then Word gave me this error about the disk being full. I figured it was because the computer freaked out over not having a scanner attached. I closed all the Photoshop error boxes, attached the scanner, and tried again. I scanned no problem, and went back to Word and was able to manually save. But every ten or fifteen minutes the same error came back up again. It suggested closing programs I wasn't using, which I did (all I have open now is Finder, Word, and Excel). But the error still comes up every ten/fifteen minutes. This past time, I went to manually save (since this error seemed to be coming up every time Word attempted to auto save) and now I get the error when I try to manually save. I went back to finder and checked (as I did when the error first appeared) and I have about 35 gigs available on my hard drive. I decided something must be going on with Word and that I'd quit and reboot and try again, but I of course didn't want to lose my work since the last save, so I tried to temporarily save the file to my external hard drive (where there is also space). But Word is telling me that doesn't have space either.

    What do I do? I would reboot to fix the problem, but I do need to save this file, and I can't reboot until I save it, but I can't save it until I reboot. Help!

    A screeshot of the error window is attached.

    EDIT: I'm using Office 2004 on a MBP with 2gigs of RAM and about 35gigs of available hard drive space (file won't save to HD, external HD, or flash drive).
     

    Attached Files:

  2. DaveF macrumors 6502a

    Joined:
    Aug 29, 2007
    Location:
    NoVA
    #2
    In Windows, Word had a bug through at least '97 that caused it to fail to save if the document had too many embedded objects. The error was similar: it thought the drive was out of space even though it wasn't. Your error sounds similar, though I don't know if it's the same.

    I had a few workarounds to this document-destroying bug. First, I'd try saving to a new filename. Next, I'd try to copy and paste the entire document into a new, blank document and try saving that. Next, I'd try to delete embedded objects -- equations in particular -- saving after each one until it saved. Then I'd try copying just the remaining text to a new doc and save that.

    Finally, I'd kill Word and pray that the last save and the auto-save feature left me with minimal lost work.
     
  3. damienjoly macrumors newbie

    Joined:
    Jun 2, 2008
    #3
    Once I got this error, the only workaround I could find was to copy everything to the clipboard, close Word, open a new document, and paste everything again.
     
  4. cyberfish88 macrumors newbie

    Joined:
    Jul 6, 2008
    #4
    Yikes, I am having the exact same problem as the original poster. It does appear to be a problem with the embedded excel file because I find that the document saves fine until I open up the embedded object to edit that.

    Any other solutions to this problem? I have a large file that i am working on with several embedded objects that I need to edit so this is a real problem.
     
  5. yuvalz macrumors newbie

    Joined:
    Jan 25, 2009
    #5
    Solution, almost perfect...

    I know this is an old thread but I encountered the same harrowing problem. I was trying to save a document in the .doc file format in Word 2008 and got the same stupid 'disk is full' error. The solution I found was surprisingly simple: save the file in the docx (Word 2007) format. You can then open the file using Word for Windows and save it back to the Word doc format. Hope this helps others who are just as freaked out.
     
  6. Froman macrumors newbie

    Joined:
    Mar 9, 2009
    #6
    Thank you

    yuvalz you just saved my freaking life! thanks so much
     
  7. dalbanese macrumors newbie

    Joined:
    Feb 4, 2009
  8. Slav2009 macrumors member

    Joined:
    Jul 18, 2009
    #8
    This thread saved my ass, thank you so much for the brilliant solution! Someone should send this to bug to Microsoft if it hasn't been addressed already
     
  9. conzoom93 macrumors newbie

    Joined:
    Feb 17, 2010
    #9
    Found solution, perfect

    Just try saving as rtf, this worked for me
     
  10. stokeyite macrumors newbie

    Joined:
    Mar 25, 2008
    #10
    more thoughts ...

    I have experienced this problem using Word 2004 and equation edition.

    First the tip on saving in word 2008 format seems to have worked :) - many thanks!

    second some thoughts on the problem:
    I found this: http://word.mvps.org/mac/diskfullerror.html - which says that the problem is caused by too many temporary files. It provides a macro that may would with office 2004 but I've not tried it. However following the logic there I tried clearing the undo list using visual basic (with activedocument.undoclear) but while this removed the availability of undo it did not solve the issue.

    This (http://dessci.com/en/support/mathtype/tsn/tsn64.htm#microsoft) seems to say that not copying and pasting OLE objects (such as equations) more than necessary should help. Copy and pasting into equation editor it suggests is OK.

    Here they suggest turning off fast saves and always setting the options to make back-ups: http://word.mvps.org/mac/CantSaveToServer.html (not sure if this is quite the same problem thought).
     
  11. JamMatt macrumors newbie

    Joined:
    Mar 27, 2011
    #11
    Thank you for the answers!

    I had this very problem last night, and I was afraid I had a virus in the Word document. I had quite a few PowerPoint slides embedded, which must have been causing the problem. I was going to take my MacBook in for a checkup/repair today, but you saved me a trip! I didn't have the option to save to .docx, but saving to .rtf did work. THANK YOU!!!
     
  12. deavet macrumors newbie

    Joined:
    Feb 7, 2012
    #12
    Word 2004 back to work

    I had the same problem since yesterday,

    I updated (all updates, one by one) the word here http://www.microsoft.com/mac/downloads
    Then I checked for any other software update,
    re-started the computer and the Word started to work again.

    weird.;)
     
  13. jvermilyea macrumors newbie

    Joined:
    Mar 9, 2012
    #13
    Similar problem, disastrous results

    Excel and Word both started generating messages yesterday, that they could not save copies of what I was working on. Word said I had too many documents open, really? One? Then it started to say there was insufficient memory. Not. I saved a document from doc to docx and it "saved." I worked on re-diting it in the evening. This morning it is gone. No trace of any docx even using finder *.docx

    Any ideas? I always see Microsoft up-sell conspiracies in these things especially when both word and excel start having issues I've never had before on the same day and hardware resource issues are not the reason (I checked my system performance dashboard in my widgets).
     
  14. veroeven macrumors newbie

    Joined:
    Apr 13, 2013
    #14
    Embedded Objects to blame for Not being able to save.

    Thank goodness I found this thread, on the first search no less!

    yes, the common problem is if one has embedded objects. I am writing a large research paper with Mac Word 2011 that has nearly 30 charts and graphs pasted and linked from an Excel file. I was getting about 1-2 hours into my work and then the auto recover feature started to fail like the original poster.

    The simple task of saving as a .doc instead of .docx cleared this up. I'm leaving my file in this format and not going back to docx. Not sure it would bring me any advantage. My charts are still linked and show up.

    The strange thing about this situation is that one can save off to a USB drive or other location and it appears to be successful, until you look at the location and nothing is there.

    Hard to believe that after 5 years Microsoft can't figure out some solution.

    Thanks again for this discussion.
     
  15. halledise macrumors 65816

    Joined:
    May 7, 2009
    Location:
    Hamilton Island, Whitsundays, QLD Australia

Share This Page