HELP: X11 won't start!

Discussion in 'Mac Basics and Help' started by linuxophile, May 16, 2011.

  1. linuxophile macrumors regular

    Joined:
    Nov 8, 2005
    Location:
    here
    #1
    Hello,

    this is a desperate call: I am at a conference with my MBP, (10.6.7, all updates done). I need Matlab for my presentation, which needs X11.
    X11 (and XQuartz) decided that they won't start anymore: the icon bounces in the dock for a while, then sits there without the little light underneath, and X11 is "non responding".

    The logs show something like this.

    I have googled and searched: similar problems once in a while appear but no posted solution.


    I tried:
    1) reinstalling XQuartz (I would reinstall X11, but how? I do not have the disks with me, I am away!)

    2) from an admin account

    3) create a new account.

    4) repair permissions.

    5) reinstall the font update from Apple that was recently issued.

    HELP PLEASE!!!

    11-05-16 5:02:01 PM [0x0-0x44044].org.x.X11[20759] X11.app: DISPLAY ("/tmp/launch-bHvQen/org.macosforge.xquartz:0") does not match our id ("org.x"), unsetting.
    11-05-16 5:02:01 PM [0x0-0x44044].org.x.X11[20759] X11.app: main(): argc=2
    11-05-16 5:02:01 PM [0x0-0x44044].org.x.X11[20759] argv[0] = /Applications/Utilities/X11.app/Contents/MacOS/X11.bin
    11-05-16 5:02:01 PM [0x0-0x44044].org.x.X11[20759] argv[1] = -psn_0_278596
    11-05-16 5:02:01 PM [0x0-0x44044].org.x.X11[20759] Waiting for startup parameters via Mach IPC.
    11-05-16 5:02:01 PM [0x0-0x44044].org.x.X11[20759] X11.app: Could not connect to server (DISPLAY is not set). Starting X server.
    11-05-16 5:02:01 PM [0x0-0x44044].org.x.X11[20759] X11.app: Launching /usr/X11/bin/startx:
    11-05-16 5:02:01 PM [0x0-0x44044].org.x.X11[20759] argv[0] = /bin/sh
    11-05-16 5:02:01 PM [0x0-0x44044].org.x.X11[20759] argv[1] = -c
    11-05-16 5:02:01 PM [0x0-0x44044].org.x.X11[20759] argv[2] = /usr/X11/bin/startx
    11-05-16 5:02:01 PM [0x0-0x44044].org.x.X11[20759] font_cache: Scanning user font directories to generate X11 font caches
    11-05-16 5:02:01 PM [0x0-0x44044].org.x.X11[20759] font_cache: Updating FC cache
    11-05-16 5:02:01 PM org.x.privileged_startx[20781] font_cache: Scanning system font directories to generate X11 font caches
    11-05-16 5:02:01 PM defaults[20791]
    The domain/default pair of (org.x.X11, dpi) does not exist
    11-05-16 5:02:01 PM [0x0-0x44044].org.x.X11[20759] Couldn't create cookie
    11-05-16 5:02:02 PM org.x.privileged_startx[20781] font_cache: Updating FC cache
    11-05-16 5:02:04 PM [0x0-0x44044].org.x.X11[20759] font_cache: Done
    11-05-16 5:02:04 PM org.x.privileged_startx[20781] font_cache: Done
     
  2. linuxophile thread starter macrumors regular

    Joined:
    Nov 8, 2005
    Location:
    here
    #2
    Solution!

    Well, there is nothing inherently wrong with x11: the problem is that about 30 files in /usr/bin are hosed! (0 file size, amongst which things like gzip, hexdump and other amenities).

    I wonder what happened! I recall a recent OSX update was hung and I had to reboot.... Surprising it did not bring down the whole system!
     

Share This Page