[HELP] Xserve 2009 SAS drive incompatible...

Discussion in 'Mac OS X Server, Xserve, and Networking' started by allenpan, Jul 27, 2017.

  1. belvdr macrumors 603

    Joined:
    Aug 15, 2005
    Location:
    No longer logging into MR
    #2
    SATA controllers are not compatible with SAS drives. However the opposite is true: you can use SATA drives on a SAS controller.
     
  2. allenpan thread starter macrumors newbie

    Joined:
    Jun 11, 2011
    #3
    My Xserve 2009 has the optional Raid card, and I believe it is SAS controller no?
     
  3. belvdr macrumors 603

    Joined:
    Aug 15, 2005
    Location:
    No longer logging into MR
    #4
    No idea what's in there. If it is SAS, then it may be that you currently have SATA drives. Even many of the new controllers don't like a mix of SAS and SATA.
     
  4. Derek Morton macrumors newbie

    Joined:
    Aug 20, 2018
    #5
    I see two likely sources of your problem:

    1 - The SAS drive(s) you are using is not compatible with the SAS controller (I do not believe you can use a 12G SAS drive in the XServe for example).

    2 - More likely, you cannot mix and match SATA and SAS (the controller is set in one mode or the other at boot). I have used both SATA and SAS drives in my 2009 XServe without any problems... But all the drives (at any given time) used the same interface (SAS or SATA).

    Hands down, the drives are the biggest issue I have had keeping my XServes running. Using NOS drives seems to work best - when I can find them.

    Best of luck!
     

Share This Page