HELP! Yosemite won't recognize exFAT USB thumb drive

Discussion in 'OS X Yosemite (10.10)' started by Mid7night, Nov 5, 2014.

  1. Mid7night macrumors newbie

    Joined:
    Nov 5, 2014
    #1
    I've got a 32GB exFAT-formatted USB drive that I use for shuttling files between work (Win7 PC) and home (Macbook Pro Retina). I up'd to Yosemite like many others after IOS8 also dropped, and didn't have any noticeable issues; until I tried plugging in my USB flash drive.

    It's completely invisible to my Mac. It doesn't auto-mount, it doesn't even show up in Disk Utility for diagnosis.

    It still loads fine on my work-PC (no surprise), but here's the kicker - It still mounts perfectly on my wife's Macbook on Mavericks.

    I plugged it into my wife's Macbook and it popped right up, copied over a file as a test, then ejected it properly and tried re-mounting on my MacbookPro; still not loading.

    Help please!? I've Googled this over and over and got nothing. What am I missing?
     
  2. T'hain Esh Kelch macrumors 601

    T'hain Esh Kelch

    Joined:
    Aug 5, 2001
    Location:
    Denmark
  3. Mid7night thread starter macrumors newbie

    Joined:
    Nov 5, 2014
    #3
    Yes. Both have worked for other devices recently.
     
  4. ddmcnair macrumors member

    Joined:
    Apr 25, 2011
    #4
    Make sure in Finder Preferences, under General External Disks is checked. I attached an image to show you what I am talking about.
     

    Attached Files:

Share This Page