Help... Youtube just stops buffering/freezing every 30 seconds!

Jonny77w

macrumors newbie
Original poster
Aug 24, 2012
1
0
Hey guys,

First post I know but i've searched the web for an answer and can't find one.

For the last few weeks Youtube just stops buffering after around 30 seconds and the slide bar at the bottom of the vid goes back to 0:00. The page or Mac are not frozen, it just needs a refresh to continue watching the Vid.

I'm using Safari, I have a IMAC 2.7 GHZ I5, 4GB using Lion 10.7.4
Its 16MB fibre optic, ethernet connected

I've reset Safari, emptied the cache and updated the newest version of flash! Can't really think what else to do!

Any input would be appreciated!:confused:
 

Imaginethe

macrumors regular
Feb 16, 2012
185
0
UK
You could try downloading Chrome or another browser to see whether it is Safari or not. If it is can you remove and readd Safari?

Also see whether you are in the HTML5 trial or not. If you are not maybe you could be added? http://www.youtube.com/html5

My PC used to do the same thing on DailyMotion, I would have to switch browsers. I never really found out the cause or the actual solution, it just started working again.
 

Srit67

macrumors newbie
Nov 6, 2012
1
0
same issue exactly ?

did you find a solution to this problem? I have the exact same thing happening, bloody annoying !
 

Gediminas Golce

macrumors newbie
Nov 8, 2012
1
0
It is not problem of Flash, Safari or Mac. I noticed, that everytime a video stops, youtube is showing "Mac keeper: is your mac getting slow?" ad. So I think, this is some kind of marketing trick, that is designed to stop loading videos ON PURPOSE, to trick users in buying "mac keeper"

Try this:
1. quit safari.
2. go to applications->utilities->terminal
3. write this string:
defaults write com.apple.Safari CustomUserAgent "\"Mozilla/5.0 (Windows; Windows NT 6.1) AppleWebKit/534.57.2 (KHTML, like Gecko) Version/5.1.7 Safari/534.57.2\""
4.press enter.

this should cause safari to report youtube webserver that you are using Safari for Windows (i.e. using not OS X, but windows), so mac keeper ads should no longer appear -> no mac keeper ads, no problems with video.

It worked for me. Videos are no longer stopping, and no "mac keeper" ads are appearing.
 

MechActor

macrumors newbie
Nov 14, 2012
2
0
Awesome Solution

It is not problem of Flash, Safari or Mac. I noticed, that everytime a video stops, youtube is showing "Mac keeper: is your mac getting slow?" ad. So I think, this is some kind of marketing trick, that is designed to stop loading videos ON PURPOSE, to trick users in buying "mac keeper"

Try this:
1. quit safari.
2. go to applications->utilities->terminal
3. write this string:
defaults write com.apple.Safari CustomUserAgent "\"Mozilla/5.0 (Windows; Windows NT 6.1) AppleWebKit/534.57.2 (KHTML, like Gecko) Version/5.1.7 Safari/534.57.2\""
4.press enter.

this should cause safari to report youtube webserver that you are using Safari for Windows (i.e. using not OS X, but windows), so mac keeper ads should no longer appear -> no mac keeper ads, no problems with video.

It worked for me. Videos are no longer stopping, and no "mac keeper" ads are appearing.

This worked perfect for me. Thanks Gediminas Golce! Brilliant solution!
I hope others can find this fix easily to save the hassle.
 

DarJul

macrumors newbie
Oct 18, 2015
3
0
It is not problem of Flash, Safari or Mac. I noticed, that everytime a video stops, youtube is showing "Mac keeper: is your mac getting slow?" ad. So I think, this is some kind of marketing trick, that is designed to stop loading videos ON PURPOSE, to trick users in buying "mac keeper"

Try this:
1. quit safari.
2. go to applications->utilities->terminal
3. write this string:
defaults write com.apple.Safari CustomUserAgent "\"Mozilla/5.0 (Windows; Windows NT 6.1) AppleWebKit/534.57.2 (KHTML, like Gecko) Version/5.1.7 Safari/534.57.2\""
4.press enter.

this should cause safari to report youtube webserver that you are using Safari for Windows (i.e. using not OS X, but windows), so mac keeper ads should no longer appear -> no mac keeper ads, no problems with video.

It worked for me. Videos are no longer stopping, and no "mac keeper" ads are appearing.
Hi. I know I must be necro posting but I messed up by following your instructions without thinking it would have other consequences, and now I cannot use websites like Whatsapp web (urgent to use it, phone broken) because they tell me to update Safari, since the website must think that I am using an old Safari in windows. So... how can I undo the Terminal command?
Sorry for the inconvenience.
 

Pearl Wisdom

macrumors member
Sep 25, 2009
62
6
I think this is the current CustomUserAgent string for Safari 9.0.2 using Mavericks. I guess you could modify this to match your own computer OS and Safari version.

Mozilla/5.0 (Macintosh; Intel Mac OS X 10_9_5) AppleWebKit/601.3.9 (KHTML, like Gecko) Version/9.0.2 Safari/537.86.3

Actually, probably easier and safer would be to go to the Safari Preferences > Advanced tab, and click the box that says "Show Develop menu in menu bar". After doing that, you should have a Develop menu in the menu bar. Go to that Develop menu, and use the User Agent menu to change it. Perhaps you might even be able to get back to the default setting by the choices there. The Terminal command might not have changed the defaults that the Develop menu uses.
 

DarJul

macrumors newbie
Oct 18, 2015
3
0
Thank you, I solved it yesterday with:
defaults DELETE com.apple.Safari CustomUserAgent
But thanks for your prompt answer!!