1. dudeitspaulwall macrumors newbie

    Joined:
    May 4, 2009
    #1
    My iPhone 4 is screwed up. I updated it with the most recent update, and when I did that the home button got loopy. It would act as though it was being pressed constantly, even though it was not physically pressed down. Therefore it would constantly go to the main home page, voice command, and the search page. It fixed itself after I turned it off for about 20 minutes. However, just a few hours ago it started again, so I decided to restore it. I restored it, and it was being reloaded from my most recent backup and after it completed backing up, it said the normal, please keep iPhone connected as it restarts. When it came on again, it was back in recovery mode, and needed to be restored again. I did this 3 or 4 times. I even updated my iTunes and tried 2 more times, but it will not come out of recovery mode, no matter how many times I restore it...
    Please help! Thanks!
     
  2. JamesMB macrumors 68000

    JamesMB

    Joined:
    Jan 2, 2011
    Location:
    Texas
    #2
    You can try to DFU restore it, or take it to Apple.
    http://www.iclarified.com/entry/index.php?enid=1034
     
  3. SandboxGeneral Moderator

    SandboxGeneral

    Staff Member

    Joined:
    Sep 8, 2010
    Location:
    Orbiting a G-type Main Sequence Star
    #3
    You also may get a better response by using this tip regarding thread titles.

    How do I get help with a hardware or software problem?

     
  4. dudeitspaulwall thread starter macrumors newbie

    Joined:
    May 4, 2009
    #4
    Hey guys, sorry about the thread title as I am new to this site. Can I update the title?
    Also I just tried the DFU mode or whatever, and that did the same thing? Anyone else have any ideas, or should I just take it into Apple?
    Thanks again guys
     
  5. eastercat macrumors 68040

    eastercat

    Joined:
    Mar 3, 2008
    Location:
    PDX
    #5
    If your home button really is screwed up, you wouldn't be able to enter DFU mode anyway. Also, I'm guessing you don't have the necessary competence to enter DFU mode anyway.
     
  6. himni macrumors regular

    Joined:
    Sep 24, 2009
    #6
    It sounds like you have a defective home button and need to take it to the apple store to get a new phone.
     
  7. dudeitspaulwall thread starter macrumors newbie

    Joined:
    May 4, 2009
    #7
    Was that really necessary?

    Anyway, I brought it to the Apple Store and they replaced it. They couldn't figure it out either. It was in an infinite loop. Thanks to all that helped!
     
  8. -aggie- macrumors P6

    -aggie-

    Joined:
    Jun 19, 2009
    Location:
    Where bunnies are welcome.
    #8
    If you care, you can change the title by going to Edit>Go Advanced
     

Share This Page