Help?

Discussion in 'Digital Photography' started by ZilSemaj, Apr 3, 2011.

  1. ZilSemaj macrumors newbie

    Joined:
    Apr 3, 2011
    #1
    This might be in the wrong area, but I will give it a shot-

    I have a Cannon Rebel T1i, and with it I have a Sony SDHC 4BG card.
    It has been used in my MacBook Pro before, and I was able to transfer the photos.
    But... It doesn't work anymore.
    I have had some issues with my computer reading hard drives in the past, but that was because they weren't formatted correctly.
    Nothing has happened out of the norm, and the card isn't locked.

    Any clues?
     
  2. Designer Dale macrumors 68040

    Designer Dale

    Joined:
    Mar 25, 2009
    Location:
    Folding space
    #2
    Try reformatting the card in the camera. Most of the folks who post photos in this forum use the camera to erase (reformat) the card instead of the computer.

    And please add more detail to your post title. Something like "My MBP Won't Read My SD Card" lets us know what you need "Help" with.

    Dale
     
  3. Seo macrumors regular

    Joined:
    Jun 1, 2009
    Location:
    Cupertino, California
    #3
    I'm guessing the card plain doesn't show up? Format it with your camera. Get into the habit of doing that often(after you get your pictures off of course!). It'll prevent situations where you're on a raft flying over some rapids and your card suddenly decides to write corrupt images, in which case you'll have to format (and lose your previous images). Personal experience. :D

    And yea, informative titles are useful. ;)
     

Share This Page