Discussion in 'Mac Help/Tips' started by Mighty Mac, Jan 20, 2003.

  1. Mighty Mac macrumors member

    Jan 10, 2002
    I have an iMac DV 400 MHz. It has been nothing but wonderful sine 1999 but the other day I tried to boot OS 9 just for a change of pace and to get some work done with out classic. My usual operating system is OS x 10.2.3. Now the computer will not start.

    I used a friend's eMac connecting the two computers through the FW ports and switched back to OSX, which worked. Then I ran Disk utility and tried to run 9 again. This time same problem, but my friend will not let me use his computer this time says he is busy with schoolwork. I have tried booting from every install disk I have 9-9.1-9.2-10-10.1-10.2 and disk tools from my APP. I would take it to my local apple store but my Protection plan just ran out in Dec 2002 :(.

    I was hoping someone would know how to switch into the boot loader during bootup so I can get this thing up and running. Any possible solutions would be really appreciated.

  2. shadowfax0 macrumors 6502

    May 2, 2002
    I think it may have gotten confused, for lack of a better term. When you restart it, hold down the option key and see what happens; if that doesn't work, post what happens and we'll see what we can do!
  3. Mighty Mac thread starter macrumors member

    Jan 10, 2002

    Although I am not in front of my computer right now, I have tried this as the nice man at the apple store told me it would show all bootable volumes. It did not display anything and I still had the blinking "?” Thank you for your thoughts.
  4. benixau macrumors 65816


    Oct 9, 2002
    Sydney, Australia
    is os9 on a different partition/disk??

    if so re-install it or, i think, do a rebuild.

    i cant help you much cause i never had an os9 computer. os7.5.3 -> jag.

    good luck
  5. teabgs macrumors 68030


    Jan 18, 2002
    behind you
    I've noticed that with 10.2.3 when you do this it does not show you OS9. Only OSX partitions....granted I dont have a seperate partition for 9, but it doesnt show that as a bootable option. The ONLY way is through the system prefs..
  6. Mighty Mac thread starter macrumors member

    Jan 10, 2002
    Same Partition

    I have been lazy and have not partitioned the disk. I was going to do that after changing the internal drive, which was planed for next weekend. Still running off original 10gig drive.

    Wish I had planed it for last weekend. My trouble now is even if I want to switch my HD I would like to burn a back up first. I think I may have to bring it over to the Apple store and get them to fix, after begging my friend one last time for use of his eMac. it. This time once it is working backup disk and new HD will be my first steps.

    Thanks for all your help.
  7. GeeYouEye macrumors 68000


    Dec 9, 2001
    State of Denial
    try holding cmnd-x at startup. see if that does anything. beyond that, the only thing i can think of is a firmware hack/script, but i've never used it, and i don't know what it is.

    EDIT: Another couple ideas: 1. Hold down the reset button for a few seconds. 2. If that doesn't work, put in a bootable CD, and if C doesn't work, hold down cmnd-crtl-shift-delete. That should force it to not try to boot from the HD.
  8. frescies macrumors regular

    Dec 9, 2002
    Los Angeles, CA
    OHHH I had the same exact problem!!!

    I just wrote about it in a thread called "g4 suddenly refusing to boot into x" or something like that.

    Here is what fixed mine.

    A boot off the Jag disk and a reinstall fixes the problem temporarily (actually it gets Jag up and running again but your 9 is still stuffed). I have the same feeling as shadowfax0. It really seems as though the computer is confused and stuck between OSes.

    If you archive and install Jag, then clean install 9 That should fix the problem.... again temporarily but more effectively..... Now your computer should Boot fine between X and 9, UNLESS you crash in 9. Then the problem will start all over again and youll have to reinstall again.

    So here is what I did.

    Back everything up.


    Make 2 partitions.

    Install Jag and a SIMPLE COPY OF 9.2.2 (no fancy extensions or fonts or anything) on one partition.

    And install 9.2.2 on the other partition (this one with all of your extensions and goodies)

    Now here's what I believe is the MOST IMPORTANT PART (aside from having a dedicated bootup volume for 9). The 9 on the same partition as X is the startup volume for "classic" I never use the other 9 for "classic". When booting up into 9 however I use the 9 that is on its own partition and never the one that is used as my "classic" startup volume. This FIXED EVERYTHING. As long as I'm not booting into the same 9 system folder that I use for "Classic" everything works fine (even when I crash in 9).

    That worked perfectly for me. I would suggest doing so as well.
    Though some may tell you that youre insane to have 9 and X on the same volume.....
  9. Mighty Mac thread starter macrumors member

    Jan 10, 2002

    I just wanted to thank everyone for all there advice thus far. I am at work and will probably not be able to try anything until, 9-10pm EST. I will make sure to write and tell you when (if) everything works out later.

    Thanks again

  10. Mighty Mac thread starter macrumors member

    Jan 10, 2002

    Thank you all for you r help. A special thanks to GeeYouEye as Cmnd X booted me into my beloved OS X.

    Thanks again

Share This Page