Hidden google updater

Discussion in 'macOS' started by lordthistle, Jan 23, 2009.

  1. lordthistle macrumors 6502

    Joined:
    Feb 29, 2008
    Location:
    Italy
    #1
    I installed Google Picasa far Mac on a 10.5.6 leopard machine.

    Today, a window told me that I should update my version of Picasa, but Picasa was not running. The updater was... well hidden.

    In fact, there is no google updater in my StartupItems. Furthermore, there is no goo* process among the running processes. The only upd* process is "update", whose function I ignore.

    Does anyone know which one is the Google Updater process?

    thistle

    PS. At Google they forgot to add "sudo" and User Authentication in the updater. The updater fails also when launched with Administrator privileges. That's funny, the mighty Google offering us such pearls of Mac programming :)
     
  2. TJMeier macrumors member

    Joined:
    Dec 28, 2008
    #2
    Same thing happened to me yesterday v1.03. I forgot I had Picasa on my computer!
     
  3. avotree macrumors newbie

    Joined:
    May 1, 2008
    #3
    I run the Little Snitch app to keep track of which programs are connecting to the internet without my permission. Yesterday I installed Google Earth. Today, Google Apps Updater has tried to phone home about a half-dozen times. And yes, G Earth is closed.

    I know Google has a "do no harm" philosophy, but that's a little invasive in my book. I notice their EULA requires installation of the Updater. What exactly are they updating if the program is closed?
     
  4. BobZune macrumors 6502a

    Joined:
    Oct 26, 2007
    Location:
    USA
    #4

Share This Page