hide dictation button in messages? (SOLVED)

Discussion in 'iOS 10' started by fisherking, Jul 26, 2016.

  1. fisherking macrumors 603

    fisherking

    Joined:
    Jul 16, 2010
    Location:
    ny somewhere
    #1
    i thought i could do this in the past, but...in ios10? is there a way to hide the mic button? i keep hitting it, getting a message about enabling dictation (which i don't want to do).

    frustrating. but...am i missing something? can it be hidden?
     
  2. T5BRICK macrumors 604

    T5BRICK

    Joined:
    Aug 3, 2006
    Location:
    Oregon
    #2
    To disable dictation, go into Settings > General > Keyboards and flip the dictation toggle.

    But I'm guessing you're actually trying to disable audio messages, which doesn't appear to be possible at the moment.
     
  3. Shirasaki macrumors 603

    Shirasaki

    Joined:
    May 16, 2015
    #3
    Flipping that switch off cannot hide that small mic button. OP should enable restriction, and turn off Siri & Dictation to remove that small mic icon.
     
  4. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #4
    Pretty sure it does in fact do that as I've done that before in iOS 8 and 9. Just tried it now and it still works. This is of course keeping in mind that this is all in relation to the dictation button that appears on the keyboard at the bottom to the left of the space key. Perhaps it works differently in iOS 10?
     
  5. sjtidy macrumors member

    Joined:
    Oct 29, 2011
    #5
    Just tested it on iOS 10 and it switching dictation to off removes the keyboard button. No need to enable restrictions.

    It does however also turn off dictation on Apple Watch, so it's not useful for me.
     
  6. Shirasaki macrumors 603

    Shirasaki

    Joined:
    May 16, 2015
    #6
    I would guess it works a bit differently on iOS 10, which forcing me to mess around with restrictions setting.
    Only time can tell. Or this is device specific.
    --- Post Merged, Jul 27, 2016 ---
    I always keep "dictation" off but that small mic only goes away after turning off Siri and Dictation in Restriction setting, for me.

    Guess it is not working properly in current iOS 10 beta. Oh, I couldn't remember how iOS 9 version goes.
     
  7. fisherking thread starter macrumors 603

    fisherking

    Joined:
    Jul 16, 2010
    Location:
    ny somewhere
    #7
    yes, seems (at least, in the beta), that siri & dictation MUST be off in restrictions...and i'd like to, at least, keep siri. for now, will get a pliers, and LIFT that button out... :D
     
  8. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #8
    So it seems like it works the same way in iOS 10 as it did before, at least as far as removing that keyboard button.
     
  9. T5BRICK macrumors 604

    T5BRICK

    Joined:
    Aug 3, 2006
    Location:
    Oregon
    #9
    No, but it does hide the button on the keyboard that is used for Dictation. And per the original post "dictation" is what was being asked about.
     
  10. Shirasaki macrumors 603

    Shirasaki

    Joined:
    May 16, 2015
    #10
    Yeah. What I say "small mic" actually refers to the dictation button.
     
  11. T5BRICK macrumors 604

    T5BRICK

    Joined:
    Aug 3, 2006
    Location:
    Oregon
    #11
    The dictation button is on the keyboard. What you're referring to is called something else. That is my whole point.
     
  12. EJ8 macrumors 6502a

    EJ8

    Joined:
    Oct 13, 2010
    #12
    Has it ever been possible to turn off audio messages (in the Messages app)? If so I didn't know about it and would love that feature. The only audio messages I've ever sent have come from my "pocket".
     
  13. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #13
    Don't think so. But at the same time I don't believe they get activated simply by tapping/touching the icon, nor is there a sound that gets made if one was to tap/touch the icon.

    It's somewhat unclear as to what the OP is really referring to. I doesn't sound like it's the voice messages since there's a mention of a message about dictation coming up, and it also doesn't sound like it's the dictation button on the keyboard since if dictation was disabled (as it appears to be in the case of OP given the message that comes up) the dictation button in the keyboard shouldn't even be there (unless something changed in iOS 10 in relation to that and/or there some bug in the betas).
     
  14. fisherking thread starter macrumors 603

    fisherking

    Joined:
    Jul 16, 2010
    Location:
    ny somewhere
    #14
    the mic button next to the '123' button. i hit it often when reaching for the numbers button, and a window pops up "Enable Dictation?" etc... i chose Not Now, and go back to what i was doing.

    one of the things i removed on previous iphones (with a jailbreak), but...done with those days lol. sad that i cannot turn that off without completely disabling siri... :(
     
  15. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #15
    That would be the dictation button. Should be removable (as it has been for some time in iOS 9 and 8 as I recall), as mentioned in various posts:
     
  16. T5BRICK macrumors 604

    T5BRICK

    Joined:
    Aug 3, 2006
    Location:
    Oregon
    #16
    Just go into Settings > General > Keyboard and flip the "Enable Dictation" toggle. IMG_2032.PNG IMG_2033.PNG
     
  17. Shirasaki macrumors 603

    Shirasaki

    Joined:
    May 16, 2015
    #17
    IMG_1300.PNG
    IMG_1301.PNG
    IMG_1302.PNG
    Then, this is what I see when Restriction setting is ON.
    IMG_1303.PNG
    IMG_1304.PNG
    IMG_1305.PNG
    And this is what I see when Restriction setting is OFF.
    Have zero idea why I need Restriction to turn off Dictation as a whole, while all of you guys in here does not need to.
    --- Post Merged, Jul 27, 2016 ---
    Alright we are not at the same boat.
    I am very clear about what I refer to IS dictation button, looking like a small microphone.
    That is my point.
     
  18. T5BRICK macrumors 604

    T5BRICK

    Joined:
    Aug 3, 2006
    Location:
    Oregon
    #18
    I'd report the issue to Apple if you haven't already.

    When the OP said they couldn't disable the button, it seemed to me that they were referring to the voice message button(I was incorrect), which also looks like a small microphone.

    I'd attach an image but for whatever reason the mobile version of the site won't allow me to upload.
     
  19. Shirasaki macrumors 603

    Shirasaki

    Joined:
    May 16, 2015
    #19
    Alright thank you for your report.
    And seems that you need to tap "more options" and try uploading photo there as this is what I am doing.
    And yeah I know audio message icon in messages app also looks like a small mic. But OP mentioned Dictation before so I don't link it with audio message mic icon.
     
  20. EJ8 macrumors 6502a

    EJ8

    Joined:
    Oct 13, 2010
    #20
    Not sure what you're saying here but more than once I have unknowingly sent audio texts. It takes a tap/hold and another tap. And you send an audio file of whatever was recorded in between the first tap/hold and the second.
     
  21. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #21
    Right, and I was saying it requires some more deliberate and/or multi-step action that doesn't really make a sound compared to simply accidentally tapping on the dictation key (that is being described and discussed by the OP and essentially others).
     
  22. fisherking thread starter macrumors 603

    fisherking

    Joined:
    Jul 16, 2010
    Location:
    ny somewhere
    #22
    here, enable dictation has been off the whole time. the only way i can remove the dictation button from messages is to turn off "Siri & Dictation" in Restrictions... but i don't want to disable siri. annoying. am periodically hitting the dictation key, then i have to click 'not now' in the "enable dictation?" pop-up, then i return to my text...

    reported to apple...
     
  23. The Mad Hatter, Jul 30, 2016
    Last edited: Jul 30, 2016

    The Mad Hatter macrumors 6502a

    The Mad Hatter

    Joined:
    Oct 12, 2004
    Location:
    SoCal
    #23
    Fisherking

    Just to be clear ... are you talking about removing the dictation button (little mic next to space bar) or the audio message button (little mic in the text field)?

    If you are talking about the dictation button ... T5BRICK is right, just UNcheck 'Enable Dictation' under General>Keyboard. It removes the button on both my 6S and iPad Air running 10pb3.
     
  24. fisherking thread starter macrumors 603

    fisherking

    Joined:
    Jul 16, 2010
    Location:
    ny somewhere
    #24
    ha. this morning, i ENABLED dictation in the keyboard settings (i've done this before, then turned it off), but this time i rebooted.. then turned it off. and the mic (next to the spacebar) is gone. SOLVED!

    thanks peeps!
     
  25. Shirasaki macrumors 603

    Shirasaki

    Joined:
    May 16, 2015
    #25
    Weird solution. But it works, and this is enough.
     

Share This Page