Hide Dock Shortcut not working

AndyAndoo

macrumors newbie
Original poster
Apr 9, 2012
10
0
New York City
Anyone else's keyboard shortcut for hiding the dock not working?

Command + Option + D in OS X Mavericks. Just updated to Mavericks yesterday.
 

Qaanol

macrumors 6502a
Jun 21, 2010
568
11
Not only does my shortcut work, but I applied a tweak so that the Dock only appears when I hit the keyboard shortcut, and does not appear on mouseover.
 

Qaanol

macrumors 6502a
Jun 21, 2010
568
11
i use an old system pref "dock gone" for this. how exactly are you doing this?
(thanx!)

To prevent the Dock from appearing on mouseover:
Code:
defaults write com.apple.dock autohide-delay -float 9999999; killall Dock;
This adds a delay of 10 million seconds (about 4 months) between the cursor reaching the edge of the screen and the start of the animation to show the Dock. If the cursor leaves the edge before then, the animation is canceled.

You can also eliminate the Dock’s slide-in animation, so it appears and disappears instantly when you press the shortcut:

Code:
defaults write com.apple.dock autohide-time-modifier -int 0; killall Dock;

While I’m mentioning Terminal command system tweaks, another good one is to enable text selection in QuickLook with:

Code:
defaults write com.apple.finder QLEnableTextSelection -bool true; killall Finder;

And of course you can reverse these changes with the following commands, respectively:

Code:
defaults delete com.apple.dock autohide-delay; killall Dock;

defaults delete com.apple.dock autohide-time-modifier; killall Dock;

defaults delete com.apple.finder QLEnableTextSelection; killall Finder;
 
Last edited:

fisherking

macrumors 604
Jul 16, 2010
6,766
1,711
ny somewhere
To prevent the Dock from appearing on mouseover:
Code:
defaults write com.apple.dock autohide-delay -float 9999999; killall Dock;
This adds a delay of 10 million seconds (about 4 months) between the cursor reaching the edge of the screen and the start of the animation to show the Dock. If the cursor leaves the edge before then, the animation is canceled.

You can also eliminate the Dock’s slide-in animation, so it appears and disappears instantly when you press the shortcut:

Code:
defaults write com.apple.dock autohide-time-modifier -int 0; killall Dock;

While I’m mentioning Terminal command system tweaks, another good one is to enable text selection in QuickLook with:

Code:
defaults write com.apple.finder QLEnableTextSelection -bool true; killall Finder;

And of course you can reverse these changes with the following commands, respectively:

Code:
defaults delete com.apple.dock autohide-delay; killall Dock;

defaults delete com.apple.dock autohide-time-modifier; killall Dock;

defaults delete com.apple.finder QLEnableTextSelection; killall Finder;

great info, thanx!