Hiding filename extensions

Discussion in 'macOS Sierra (10.12)' started by Cavara34, May 12, 2017.

  1. Cavara34 macrumors member

    Joined:
    Aug 14, 2012
    #1
    So due to a bug, it seems, I'm no long able to create desktop shortcuts that use the page name and not the raw url. I'm now using the deskCut app, which solves that, but it creates shortcuts with the .webloc extension visible, which I don't want, nor do I want to have to manually remove it for each shortcut separately. The Finder preferences option doesn't solve this. Is there another way? Thanks.
     
  2. Yahooligan macrumors 6502a

    Yahooligan

    Joined:
    Aug 7, 2011
    Location:
    Illinois
    #2
    First thing I would do is right-click/ctrl-click the file and click "Get Info" to make sure the filename in the "filename and extension" box is what you expect. It possible the filename is foo.webloc.bar and the .bar extension is being hidden, making the .webloc portion be part of the filename so it's displayed.

    Something to check if you're not seeing the extension for other files, anyway.
     

Share This Page