Hiding hidden folders in Mavericks

Discussion in 'OS X Mavericks (10.9)' started by dan92w, Oct 23, 2013.

  1. dan92w macrumors newbie

    dan92w

    Joined:
    Oct 23, 2013
    #1
    Hi! I'm a first-timer on here, posting because I can't find any helpful info elsewhere online.

    I chose to show hidden folders before upgrading my OS so I could create a bootable hard drive. However, seeing the folders that normally don't appear is now getting annoying, and I'd like to hide them again - the problem being that no script does it. I've tried 'defaults write com.apple.finder AppleShowAllFiles FALSE' and various iterations thereof, making sure capitalisation is correct, but to no avail. Terminal tells me folders are being shown - it knows that much - but won't hide them.

    Any thoughts? Tips?
     
  2. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #2
    I have not tried this in Mavs, but the below Terminal commands work in Mountain Lion.


    To hide hidden files:

    Code:
    defaults write com.apple.finder AppleShowAllFiles -bool NO
    To show hidden files:

    Code:
    defaults write com.apple.finder AppleShowAllFiles -bool YES
    Reset the Finder after each command with this:

    Code:
    killall Finder
     
  3. dan92w thread starter macrumors newbie

    dan92w

    Joined:
    Oct 23, 2013
    #3
    Must be a bug in Mavericks

    Thanks for commenting - I put the code through Terminal, but no success; everything's as before. I think it must be a bug Apple still needs to work through - I guess I'll have to hold out until the 10.9.1 release.
     
  4. Mr Rabbit macrumors 6502a

    Mr Rabbit

    Joined:
    May 13, 2013
    Location:
    'merica
    #4
    defaults write com.apple.finder AppleShowAllFiles -bool FALSE

    Just tried showing all with TRUE and disabling with FALSE, using killall Finder in-between and it worked fine using 10.9. You might try renaming or deleting your Finder preference file, it might be stuck since the change was made prior to the upgrade. Should be located in ~/Library/Preferences.
     
  5. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #5
    Hmmm... either the command I gave you or the one Rabbit gave you should work. Are you copy/pasting from here to make sure you don't have a typo? After the first command and enter in Terminal you need to separately run the killall Finder command.

    I just tested the commands I gave you on Mavericks and it unhides then hides hidden files.

    What folders specifically are you talking about and where do you see them?
     
  6. koban4max macrumors 68000

    Joined:
    Aug 23, 2011
    #6
    to reveal library: go to your main folder and press command + J...click unhidden library or something like that.
     
  7. dan92w thread starter macrumors newbie

    dan92w

    Joined:
    Oct 23, 2013
    #7
    Solved!

    Thanks all - the problem was, as Rabbit suggested, that switching OS's had messed up my Finder pref's. After deleting the plist file, I entered the command given into Terminal (yes, copying and pasting)...and voilà!
     
  8. Mr Rabbit macrumors 6502a

    Mr Rabbit

    Joined:
    May 13, 2013
    Location:
    'merica
    #8
    Great! Glad you got it sorted!
     

Share This Page