hiding menu bar in mail.app

Discussion in 'Mac Apps and Mac App Store' started by dot.ducky, Mar 20, 2012.

  1. dot.ducky, Mar 20, 2012
    Last edited: Mar 20, 2012

    dot.ducky macrumors newbie

    Joined:
    Mar 5, 2011
    #1
    Ok, so I've been trying to make my desktop a little more barren. I've added the LSUIPresentationElement to mail info.plist both manually with textedit and with plistedit pro. Each time I add the key, mail changes to a MobileMe account rather than the built-in iCloud function... What do I do to solve this without taking out the additional key?
     
  2. dot.ducky, Mar 21, 2012
    Last edited by a moderator: Mar 21, 2012

    dot.ducky thread starter macrumors newbie

    Joined:
    Mar 5, 2011
    #2
    The effects of <key>LSUIPresentationMode</key> on OS X Lion 10.7.3 apps

    If anyone has read my previous call for help, you'll recall that the Mail app reverts to MobileMe support when the LSUIPM key with an integer of 4 is presented to the info.plist. I have been doing some more testing and have come to give a report on what this key adds, or takes away, from my applications.

    Safari - 5.1.3 - With the implementation of the key, all AutoFill ceases to function properly. I have not noted any other anomalies.

    iTunes - 10.6 - Upon introduction, the key seems to affect the video playback of HDCP-enabled files. I could not play my newer 1080p movies, as iTunes reported the display device as not being compatible with the technology.

    TextEdit - 1.7 - Oh my God. The application stop working completely. I tried to restart my computer, but it refused. I had to end up repairing my install.

    AppCleaner - 2.0.5 - The Smart Delete function doesn't work for half the time. If it gets turned off on it's own, and you restart the Smart Delete, the program throws a code-signing error. Everything else seems to work properly.

    Parallels Desktop - 7.0.15055 - The app doesn't load anything. I think it threw some kind of error, but I don't recall what it was. I just tried it again after deleting the key, and it says the same error... It could just be me. Something about not being able to get through the firewall, even though it's open in the firewall preferences.

    I won't update this anymore, since I don't want to have applications that don't work, but if anyone else has reports on the effects, write it up. If anyone has a workaround that actually works, please tell us!
     

Share This Page