High "kernel_task" CPU usage and hyperactive fan, even after hardware repairs and OS reinstall

Discussion in 'OS X Mavericks (10.9)' started by sbeneitone, Nov 18, 2015.

  1. sbeneitone macrumors newbie

    Joined:
    Nov 18, 2015
    #1
    Hi all,

    For the past 2-3 months I've been unsuccessfully dealing with a problem with my MacBook Pro (Retina, 13-inch, Late 2013, Mavericks). The fan runs very loudly, "kernel_task" consistently uses ~300% of the CPU, and the computer runs very slowly as a result. After erasing the hard drive and reinstalling OS X, the problem persisted, leading me to believe it was a hardware problem, so I brought it into Apple for repairs. Sure enough, their tests returned the following sensors as failed:
    -Ambient air sensor
    -CPU Proximity
    -DDR3 Proximity
    -Right Fin Stick Proximity
    -Light Sensor

    They replaced the main logic board, top case w battery, and I/L board, and when I got it back, the fan and "kernel_task" CPU usage appeared to be fixed, but the moment I restored my data, the fan became loud again, and the boot up loading bar hung at ~50%. I couldn't even boot up until I erased the drive again, but after doing so and reinstalling the OS X, the fan and "kernel_task" were still problematic, and restarting with "D" pressed returned the following error codes:
    -PFM006
    -NDC001
    -PPN001

    I'm completely baffled at this point. I'm not even sure if this is a hardware or software problem anymore. If I could figure out how to fix the problem, I would proceed by restoring only non-system affecting data from my backup and reinstalling applications I still need, but now the problem persists even on a fresh reinstall. I don't want to send the computer away again for a problem that cold be caused by software.

    My instinct now is that some kernel extension is causing the problem (does a OS reinstall reset these?), so I looked through the console logs and found what might be a clue:
    "11/18/15 7:04:59.000 AM kernel[0]: SMC::smcReadKeyAction ERROR: smcReadData8 failed for key LsNM (kSMCKeyNotFound)
    11/18/15 7:04:59.000 AM kernel[0]: SMC::smcReadKeyAction ERROR LsNM kSMCKeyNotFound(0x84) fKeyHashTable=0x0
    11/18/15 7:04:59.000 AM kernel[0]: SMC::smcGetLightshowVers ERROR: smcReadKey LsNM failed (kSMCKeyNotFound)
    11/18/15 7:04:59.000 AM kernel[0]: SMC::smcPublishLightshowVersion ERROR: smcGetLightshowVers failed (kSMCKeyNotFound)
    11/18/15 7:04:59.000 AM kernel[0]: SMC::smcInitHelper ERROR: smcPublishLightshowVersion failed (kSMCKeyNotFound)
    11/18/15 7:04:59.000 AM kernel[0]: Previous Shutdown Cause: 3
    11/18/15 7:04:59.000 AM kernel[0]: SMC::smcIH WARNING: unexpected interrupt: 0x55
    11/18/15 7:04:59.000 AM kernel[0]: SMC::smcIH WARNING: unexpected interrupt: 0x54"

    However, I'm unsure of how to proceed. Any advice or requests for further info would be vastly appreciated.

    Sam

    PS: already tried resetting PRAM and SMC.


    MacBook Pro (Retina, 13-inch, Late 2013), OS X Mavericks (10.9.5)
     
  2. Rodan52 macrumors regular

    Rodan52

    Joined:
    Sep 21, 2013
    Location:
    Melbourne, Australia and Bali, Indonesia
    #2
    My best suggestion; download and run OnyX on the full maintainence script with all boxes ticked. Get the version for your OS (versions are OS specific) and it is free from Titanium software. Do not be distressed if the initial HD verification process seems to get stuck about a third of the way, this is normal. Let us know how that works because unless the techs missed something this sounds like a software issue.
     
  3. sbeneitone thread starter macrumors newbie

    Joined:
    Nov 18, 2015
    #3
    Thanks so much for the response.

    I tried running OnyX with all maintenance scripts and even did the cleaning scripts for good measure, but neither fixed the problem. I wanted to ask a couple of general questions to get a better idea of possible solutions:
    -Is it even possible that this is a software problem seeing how it's happening even now on an erased drive and fresh OS install? Do certain system files not get deleted during this process?
    -Is it possible that something in my software consistently causes a piece of hardware to irreversibly fail?
     
  4. JohnDS macrumors 65816

    Joined:
    Oct 25, 2015
    #4
  5. klflv macrumors newbie

    Joined:
    Oct 27, 2016
    #5
    Any solution found?

    I'm having similar problems. Bought used MBA mid 2013, when testing and afterwards (it had OSX Sierra installed) everything seemed normal (used for few hours), then decided to fully restore it and after wiping ssd and installing fresh OS had the same kernel_task problem with fan at full speed. Diagnostics gave the same codes (FM006,NDC001,PPN001). No idea where to look next.
     
  6. sbeneitone thread starter macrumors newbie

    Joined:
    Nov 18, 2015
    #6
    Apple ended up just replacing my computer, after a few failed repair attempts. Wish I could be of more help.
     
  7. klflv, Nov 1, 2016
    Last edited: Nov 1, 2016

    klflv macrumors newbie

    Joined:
    Oct 27, 2016
    #7
    Thank's for answer! Hour ago I received it back from Apple service. In my case (warranty is expired) the only solution they offered is to replace motherboard (510€) as "SMC cannot access sensor data". Tomorrow I'm trying some non-official repair shops, maybe they can replace just the sensors or offer other fixes that Apple don't offer.

    Update: just applied this workaround and it seems to work for now: https://www.davidschlachter.com/misc/kernel_task
     

Share This Page