High pings to router - slow internet

Discussion in 'Mac OS X Server, Xserve, and Networking' started by Mike.K, Oct 17, 2008.

  1. Mike.K macrumors newbie

    Joined:
    Oct 17, 2008
    #1
    The background: Hi, I'm using a WGR614v9 Netgear router and I've had a few problems with it. It recently wasn't giving my Macbook an IP, that seems to of been fixed now - sometimes it doesn't accept the WPA first time and I have to press ok a few times, but I assume this is related to the problem below.

    The problem: Basically the internet is really slow. I've downloaded MenuMeters as told in the tutorials above, but I don't think it's helping in this case. When I ping my router when connected through wireless I get this:

    Macintosh-2:~ Kent$ ping 192.168.1.1
    PING 192.168.1.1 (192.168.1.1): 56 data bytes
    64 bytes from 192.168.1.1: icmp_seq=0 ttl=64 time=341.501 ms
    64 bytes from 192.168.1.1: icmp_seq=1 ttl=64 time=512.011 ms
    64 bytes from 192.168.1.1: icmp_seq=2 ttl=64 time=35.555 ms
    ^C
    --- 192.168.1.1 ping statistics ---
    3 packets transmitted, 3 packets received, 0% packet loss
    round-trip min/avg/max/stddev = 35.555/296.356/512.011/197.114 ms

    When I ping it when connected through ethernet (which works 100% fine) the results are <1ms. My friend has an XP based laptop and his wireless is working fine - connects first time and when pinging the router gets results of less than 1ms.

    Ive done all the basic checks I can think of - such as checking the signal strength (full bar) and making sure the router is in view. When the laptops are side by side the speed difference is remarkable. Even when his laptop doesn't share the connection the pings are still high. Any suggestions please?
     
  2. savar macrumors 68000

    savar

    Joined:
    Jun 6, 2003
    Location:
    District of Columbia
    #2
    That's a strange problem. I wish I could be of more help, but I can only think of the following basics:

    1) Disconnecting and reconnecting the wireless?
    2) Did you try restarting the Mac?
    3) What happens when you take your Mac to another wifi hot spot?

    Once advanced option that *may* be worth trying is to put the router onto a different channel (usually they default to channel 6, but you could pick any channel from 1 to 11 I think).

    Also you may want to experiment with whether switching between unencrypted, WPA, and WPA2 makes any difference.

    Sometimes there are weird interactions between specific pieces of hardware and they just don't work well together. Unfortunately, I've noticed that MacBooks (my mom's and my own) both seem to demonstrate this behavior with routers that otherwise worked fine for several years with other computers.
     
  3. belvdr macrumors 603

    Joined:
    Aug 15, 2005
    #3
    To be honest, I have had nothing but bad luck out of every NetGear router I've had, and so has everyone else I've known.

    I'd recommend getting a different brand. I have had great luck with the Linksys WRT54GL routers.
     
  4. Mike.K thread starter macrumors newbie

    Joined:
    Oct 17, 2008
    #4
    I've restarted my mac and the router loads of times and im currently on channel 8 (istumbler picked up the other networks around here and they were on channels 1,6 and 11, so i picked a different one)

    Connecting it to the insecure one next door is fine, which is weird. Also, this time last week it was working fine with this router, but over the course of the week its slowly got...well... slower.
     
  5. myjay610 macrumors regular

    Joined:
    Jan 6, 2008
    #5
    Might want to also make sure everything you have is up to date. Check the netgear site and see if they have a newer firmware downloaded. Also make sure the mac is updated to the newest version. You never know...
     
  6. ChrisA macrumors G4

    Joined:
    Jan 5, 2006
    Location:
    Redondo Beach, California
    #6
    Sounds like a problem with the radio transmitter or with interference. "signal strength measures only one direction. Problem might be in the other direction.. Try your notebook with another router, like maybe in a library.
     
  7. plinden macrumors 68040

    plinden

    Joined:
    Apr 8, 2004
    #7
    Does it work better with WEP and no encryption?

    I had a similar, but not identical, problem with a WGR614 router. Two other Macs, an iPhone and a PC worked perfectly, but my iMac had 20% packet loss just pinging the router, but only when using WPA. WEP/no encryption were fine.

    It didn't bother me too much since I kept it connected via ethernet, but when the WGR614 started requiring daily restarts, I got a new AEBS, and all my Macs work fine now with WPA (and I got rid of a cable).
     
  8. Mike.K thread starter macrumors newbie

    Joined:
    Oct 17, 2008
    #8
    Its the same with WEP or WPA, even with no encryption/protection the pings are still high - connect gets dropped a fair bit too.

    Seems to be just this router too, as the router in work is fine. But why with just a Mac? My mates XP laptop picks up the network fine..

    Strange thing is though, all this week the connect has been fine... then all of a sudden again tonight it dropped and won't connect again tonight.

    Might buy a new router to test it out, if that doesn't solve it i guess i could always take the new router back.
     

Share This Page