High Sierra 10.13.4 Beta discussion

dianeoforegon

macrumors 6502a
Original poster
Apr 26, 2011
907
137
Oregon
Just downloaded and installed 10.13.4 Public beta. It took approx 40 minutes.

When I logged in I got several warnings for my 32-bit apps. OfficeTime was the one app that I use a lot where the others could be easily replaced.

<Name of App> may affect the performance of your Mac.
The developer of this app needs to update it to improve it's compatibility.

I'm using Office 2016. Any Office 2011 users see a waring for Office 2011?
 
  • Like
Reactions: powerocool

m-e

macrumors regular
Aug 6, 2015
212
55
Anyone having the "Enable Messages on iCloud" greyed out on the public beta ?

EDIT : Quitting the app/launching the app solved it.

There is a difference between this version of Messages on iCloud and the previous one : this one doesn't let you force sync nor it shows you if sync is done...
 
Last edited:

K4LK

macrumors 6502
Jun 18, 2009
383
66
After updating my mid-2014 15" rMBP to 10.13.4 beta 1, the UI hangs at the login screen. After entering my password, the bar graph gets about 90% full and the beach ball below it stops spinning. I can tell the rMBP is running because Time Machine backups are occurring. I can only use this MBP in safe mode by holding down SHIFT when starting up. Submitted a bug report to apple with sysdiagnose.
 

fisherking

macrumors 604
Jul 16, 2010
6,729
1,690
ny somewhere
After updating my mid-2014 15" rMBP to 10.13.4 beta 1, the UI hangs at the login screen. After entering my password, the bar graph gets about 90% full and the beach ball below it stops spinning. I can tell the rMBP is running because Time Machine backups are occurring. I can only use this MBP in safe mode by holding down SHIFT when starting up. Submitted a bug report to apple with sysdiagnose.
can you reinstall the update? and/or install from recovery?
 

K4LK

macrumors 6502
Jun 18, 2009
383
66
There is no way to re-install. My only choice is to run in safe mode until apple fixes the bug or downgrade to 10.13.3
 

m-e

macrumors regular
Aug 6, 2015
212
55
My Preview app is have problem rendering jpg, png images, PDF renders fine, anybody having this problem ?
Nope works fine on mine (MBPr 2015)
[doublepost=1517083382][/doublepost]
Anyone having the "Enable Messages on iCloud" greyed out on the public beta ?

EDIT : Quitting the app/launching the app solved it.

There is a difference between this version of Messages on iCloud and the previous one : this one doesn't let you force sync nor it shows you if sync is done...
In fact it shows a progression bar when sync is ongoing at the bottom of the list of your message. But no "sync now button"and I guess this is not an omission.
 

K4LK

macrumors 6502
Jun 18, 2009
383
66
you can't boot into recovery? if we're not all experiencing this, there may not be something for apple to fix.
Yes, I have and checked disk. Also checked disk in single-user mode. I can wipe disk, install 10.13.3 and migrate data. My T.M. backups are 10.13.4. Beta 2 of HS was also a train wreck for me. This rMBP was kernel panicking. I went back to Sierra and waited until the 6 beta before going back up to HS. When will I learn to clone the SSD before going to the first beta of the next point release ?
 

fisherking

macrumors 604
Jul 16, 2010
6,729
1,690
ny somewhere
Yes, I have and checked disk. Also checked disk in single-user mode. I can wipe disk, install 10.13.3 and migrate data. My T.M. backups are 10.13.4. Beta 2 of HS was also a train wreck for me. This rMBP was kernel panicking. I went back to Sierra and waited until the 6 beta before going back up to HS. When will I learn to clone the SSD before going to the first beta of the next point release ?
yeah, carbon copy cloner is your friend. meanwhile, something's up with your hardware..or?? meanwhile, if i were having this experience, i'd bow out of the beta program immediately... anyway, good luck!
 
  • Like
Reactions: TheStork

stradify

macrumors member
Jul 4, 2015
74
20
USA
Anyone else finding 'dark mode' not working properly? Most of the icons in my menu bar are almost invisible including the Apple Menu icon. They're there but almost impossible to see. The drop down menus appear close to what they should be for some but not others such as Wifi which has the locks and fans greyed out. Turning off 'dark mode' returns the menu bar to normal. Here's what it looks like with dark mode on.
DarkIconProblem.png


I edited my original post regarding my Adobe Apps not working in this beta. Well, now they work!
Don't ask me why as I didn't do anything. By the way, this is an early 2011 macbook pro.
 
Last edited:

fisherking

macrumors 604
Jul 16, 2010
6,729
1,690
ny somewhere
Anyone else finding 'dark mode' not working properly? Most of the icons in my menu bar are almost invisible including the Apple Menu icon. They're there but almost impossible to see. The drop down menus appear close to what they should be for some but not others such as Wifi which has the locks and fans greyed out. Turning off 'dark mode' returns the menu bar to normal. Here's what it looks like with dark mode on.View attachment 748823

Regarding the 32 bit apps, I found that some work and others are toast. Adobe CS4 Photoshop and Illustrator are done.
Adobe Contribute 6.5 loads but won't allow edits as it won't connect so I'm going to have another look at it to see if I can get it working. AccountEdge Pro 2017 works fine as well as 2011 Excel. Scrabble 1.0 fans will be glad to know that it works just fine. How long these 32 bit apps will continue to work is questionable as Apple continues to move further away from support for 32 bit apps.
dark mode is fine here. and the 32bit apps will survive until the next official os (10.14)... am already planning for that (sigh)...
 
Hi guys. I am new to this forum as a poster but have enjoyed the beyond awesome information which has helped me over the years by "lurking". I am now reaching out for advise as I made the moronic move and upgraded to 10.13.4 Beta (I should've stayed away from "Beta" in the first place). I use a 2012 Mac mini 2.5 GH Intel C I5, 16gb Ram, Intel 4000 graphics for work. I have 3 monitors running: 2 ASUS 27 inch and 1 50 Inch Samsung. 1 ASUS use the display port while the other is hooked up to a USB 3 port via a Diamond HDMI-USB adapter. The Samsung use the HDMI port. I use Display Link's 4.0 driver software. Before I upgraded to 10.13.4 Beta it was running flawlessly. I use all 3 monitors for my work as I need to have visual access to several running applications at the same time....Currently my one monitor (ASUS with the Diamond adapter shows up in my hardware and system preferences ( displays) but only shows a bright yellow screen while my trackpad cursor is visible on there.

I realize that 10.13.4 Beta is the culprit. Being desperate I am asking for advise to find out IF there is a way to either downgrade or get out of the Beta program and re-install the public current version?. Sadly I have no back up of previous Beta versions but hope I will be able to to a complete back up of all my content, wipe the Hard drive and reinstall a previous OS then ad my apps and content ??

Missing that 3rd monitor will significantly affect my work productivity....

I appreciate all / any advise....lesson learned...
 

LarryJoe33

macrumors 68000
Jul 17, 2017
1,566
505
Boston
Hi guys. I am new to this forum as a poster but have enjoyed the beyond awesome information which has helped me over the years by "lurking". I am now reaching out for advise as I made the moronic move and upgraded to 10.13.4 Beta (I should've stayed away from "Beta" in the first place). I use a 2012 Mac mini 2.5 GH Intel C I5, 16gb Ram, Intel 4000 graphics for work. I have 3 monitors running: 2 ASUS 27 inch and 1 50 Inch Samsung. 1 ASUS use the display port while the other is hooked up to a USB 3 port via a Diamond HDMI-USB adapter. The Samsung use the HDMI port. I use Display Link's 4.0 driver software. Before I upgraded to 10.13.4 Beta it was running flawlessly. I use all 3 monitors for my work as I need to have visual access to several running applications at the same time....Currently my one monitor (ASUS with the Diamond adapter shows up in my hardware and system preferences ( displays) but only shows a bright yellow screen while my trackpad cursor is visible on there.

I realize that 10.13.4 Beta is the culprit. Being desperate I am asking for advise to find out IF there is a way to either downgrade or get out of the Beta program and re-install the public current version?. Sadly I have no back up of previous Beta versions but hope I will be able to to a complete back up of all my content, wipe the Hard drive and reinstall a previous OS then ad my apps and content ??

Missing that 3rd monitor will significantly affect my work productivity....

I appreciate all / any advise....lesson learned...
Oh man, that sucks. I'll spare you the verbal spanking you should get for 1) not having a backup (clone) of something to fall back on, 2) using your work machine for beta testing!

Ok, try to save everything you can to an external drive or device other than your boot drive. Boot into recovery mode (command+r) and reinstall the OS.
 
  • Like
Reactions: Emma's Dad

MAlexB

macrumors member
Oct 10, 2017
46
11
Just upgraded to 10.13.4b1 via 10.13.3 and do not have any problems, even the dark mode works exactly as before!
Those who have problems, did you go directly from 10.13.3b to 10.13.4b or also via 10.13.3?
 

maflynn

Moderator
Staff member
May 3, 2009
63,851
30,368
Boston
Odd issue is that the message app is sending txts via SMS (green bubbles), where is if I respond to the same message thread on my phone its using the message platform (blue bubbles).

Another bummer is that I did not specifically choose to update my Mac to 10.13.4, yet I woke up this morning and waking up my mac, it started the update process. I don't normally have automatically udpates turned on but I suspect it was flipped on by the last beta image ¯\_(ツ)_/¯
 

jdclifford

macrumors 6502
Jul 26, 2011
427
566
Has anyone else noticed "No Local Dictionary Available" issue when using right click "Lookup..."? Worked fine thru 10.13.3
 
  • Like
Reactions: Klososky