High Sierra defaults wallpaper on restart

thomatkinson

macrumors newbie
Original poster
Oct 28, 2017
2
7
Hi,

I recently did clean installation of High Sierra. Since then I'm having an issue with the desktop wallpaper - I set it to a solid colour grey but every time I restart it returns to the default wallpaper image of a mountain. Has anyone found the same problem or a solution?

Thanks,
Thom
 
  • Like
Reactions: Ditoni and DeepIn2U

thomatkinson

macrumors newbie
Original poster
Oct 28, 2017
2
7
Ok, I fixed it. I suspect the problem was related to my having two displays. The solutions was as follows:

Go to System Preferences > Mission Control and uncheck "Displays have different spaces". Choose your wallpaper for each display and restart. It should stick.
 

eiuro

macrumors member
Feb 28, 2013
61
17
Ok, I fixed it. I suspect the problem was related to my having two displays. The solutions was as follows:

Go to System Preferences > Mission Control and uncheck "Displays have different spaces". Choose your wallpaper for each display and restart. It should stick.
Love when people solve problems and actually post the answer when they fix it! Thank you soooo much for this.
 

Ish

macrumors 68020
Nov 30, 2004
2,056
463
UK
Ok, I fixed it. I suspect the problem was related to my having two displays. The solutions was as follows:

Go to System Preferences > Mission Control and uncheck "Displays have different spaces". Choose your wallpaper for each display and restart. It should stick.
Thank you!
 

DeepIn2U

macrumors 603
May 30, 2002
6,367
1,813
Toronto, Ontario, Canada
Ok, I fixed it. I suspect the problem was related to my having two displays. The solutions was as follows:

Go to System Preferences > Mission Control and uncheck "Displays have different spaces". Choose your wallpaper for each display and restart. It should stick.
THANK YOU!

This occurred to me on my '18 MBP 13" while connected to my TV. Oddly enough I've powered down, disconnected the TB to HDMI adapter several times before and this didn't occur, even though my Sys Prefs > Mission Control "Displays have different spaces" was enabled as before.

For me my wallpaper changed to the same Blue background as what I was viewing in a LinkedIn course for High Sierra for a few hours yesterday to brush up my skills. I only downloaded course files: Mp4, png and MS Word/Excel work files as part of the course in the Downloads folder. Nothing installed, no updates. Then Boom I see this happening: freaked me right out!

Again much appreciated for the tip!

PS: This requires a log-out to take affect.

Love when people solve problems and actually post the answer when they fix it! Thank you soooo much for this.
Indeed!

Cheers.
 

DeepIn2U

macrumors 603
May 30, 2002
6,367
1,813
Toronto, Ontario, Canada
DOH!

Something is very wrong with this setting.

First why is it in Mission Control when it's a Desktop Setting?

Secondly, with the option set to OFF, I updated my MBP with supplemental update 10.13.6.2, specific to the 2018 MBP issued earlier this week (I applied it last night after my time machine backup) and without being connected over HDMI to my TV, upon boot and logon I still have the default blue wallpaper. I changed the wallpaper by highlighting a jpeg in my folders (home folder > pictures) and no changes occurred. Hmm.
 

pparker88

macrumors newbie
Dec 18, 2018
1
0
Ok, I fixed it. I suspect the problem was related to my having two displays. The solutions was as follows:

Go to System Preferences > Mission Control and uncheck "Displays have different spaces". Choose your wallpaper for each display and restart. It should stick.
OMFG. Thank you.
I've spent the last few days sifting through countless threads about deleting an irrelevant com.apple.desktop.plist file before finding this post.
 

AnonMac50

macrumors 65816
Mar 24, 2010
1,497
286
DOH!

Something is very wrong with this setting.

First why is it in Mission Control when it's a Desktop Setting?

Secondly, with the option set to OFF, I updated my MBP with supplemental update 10.13.6.2, specific to the 2018 MBP issued earlier this week (I applied it last night after my time machine backup) and without being connected over HDMI to my TV, upon boot and logon I still have the default blue wallpaper. I changed the wallpaper by highlighting a jpeg in my folders (home folder > pictures) and no changes occurred. Hmm.
It’s the way desktop backgrounds are handled by macOS. When Mission Control is set to have the same spaces on both displays, the same number of spaces will be together and the wallpapers will be matched too. Unchecking that box makes each space independent.
 
  • Like
Reactions: DeepIn2U

Cole637

macrumors newbie
Aug 6, 2015
10
0
Ok, I fixed it. I suspect the problem was related to my having two displays. The solutions was as follows:

Go to System Preferences > Mission Control and uncheck "Displays have different spaces". Choose your wallpaper for each display and restart. It should stick.
Unchecking the box worked for me! Thank You!!