High sierra won't format new drives

Discussion in 'macOS High Sierra (10.13)' started by oscarodas, Oct 21, 2017.

  1. oscarodas macrumors regular

    Joined:
    May 7, 2013
    Location:
    Sydney Australia
    #1
    Hi, yesterday I bought a new 8tb WD external hard drive, it came formatted as exFat, I tried to format it to HFS but after a few seconds it failed and I got the message drive failed to unmount, then the driver dissapeared, Disk Utility would display it as disk5s1 but every attempt at formatting the disk would fail, took it to a pc and formatted again but my iMac wound;t see it, even the experts at apple place couldn't format it and I was told to try and get a new one, in desperation I took it to a friend who owns a 2007 mac mini , as soon as I plugged the drive it offered to initialise it, and I was able to use it, I thought this a bit odd and tried two old drives formatted as ms-dos and the same thing thing again, and I'm sure it is High Sierra because I did installed Parallels and Windows 10, which sees and formats the drives but back to High Sierra the drives disappear even after a few re-boots, is there something am I missing?
     
  2. Fishrrman macrumors P6

    Fishrrman

    Joined:
    Feb 20, 2009
    #2
    "is there something am I missing?"

    Does the WD drive have a "hidden, proprietary partition", perhaps with some specialized WD software on it? Software intended for security, disk management, etc.?

    Sometimes "pre-packaged" drives come this way out-of-the-box.
    The presence of such a partition could prevent Disk Utility from properly re-initializing the drive.

    I personally have bought one USB flashdrive like this (Sandisk drive some years ago). It came with a proprietary partition that could not be removed on the Mac (at that time). I actually had to take it back to where I bought it (Circuit City, remember them?), and have a tech there remove the software using a Windows computer. After that was done, I then could re-initialize the drive to HFS+ ...
     
  3. oscarodas thread starter macrumors regular

    Joined:
    May 7, 2013
    Location:
    Sydney Australia
    #3
    Well, that makes sense, because the driver had some software installed , also installed an icon on the top bar called WD Discovery and I can't get rid of it.But it doesn't make sense because the only way I was able to format the drive was with a mac mini running Snow Leopard.
     
  4. LarryJoe33 macrumors 65816

    LarryJoe33

    Joined:
    Jul 17, 2017
    Location:
    Boston
    #4
    Have you tried booting to High Sierra recovery mode and using DU there to erase and format the drive?
     
  5. oscarodas, Oct 21, 2017
    Last edited: Oct 22, 2017

    oscarodas thread starter macrumors regular

    Joined:
    May 7, 2013
    Location:
    Sydney Australia
    #5
    Yes, I did, I also tried formatting using Terminal, to no avail, but as I explained the only way to do it was a 2007 mac mini . Could it be Hardware related? I'm running High Sierra 10.13.1 Beta (17B35a).
    Today to have peace of mind I tried an Intel 160GB ssd which I bought very cheap a few weeks ago and I had the same trouble as with the 8tb drive, went to the same friend and yes his old mini formatted the ssd first go, about one minute. I'm going to install an old os x version on the ssd, boot my iMac and see if it can format the drives normally....
     
  6. dsnorris macrumors newbie

    dsnorris

    Joined:
    Dec 1, 2017
    #6
    i am having the same issue with a 4GB seagate eternal hard drive - can't format in high sierra - wanted to use it for a time machine back up but had to format the drive in Windows 10 as a exFAT - when ever I try to erase the drive using either time machine or disk utility it fails. I tried partitioning the drive using OS Extended (Journaled) and it fails every time. This is the second hard drive that this is happening with.

    Any help would be appreciated
     
  7. oscarodas thread starter macrumors regular

    Joined:
    May 7, 2013
    Location:
    Sydney Australia
    #7
    --- Post Merged, Dec 1, 2017 ---
    Hi, today after seeing your post I tried formatting an external Microsoft ssd drive and it was successful, I'm running High Sierra 1013.2 Beta (17C83a). Also TotalFinder and PathFinder are working ok.
     
  8. Honza1 macrumors regular

    Joined:
    Nov 30, 2013
    Location:
    US
    #8
    I had many problems with Disk utility on High Sierra, formatting is one of them.
    I found out, that most drives I needed to format I can - eventually.

    Step 1 is generally eject the drive. Disk utility in HS seems to fail more than succeed in unmounting the drive on their own.
    Step 2 - once the drive is ejected, select the greyed out drive in Disk tools and partition or "erase" as you want. Usually, on third or fourth attempt the formatting succeeds and drive is generally OK. Apple file systems are easier to create than others - few days ago I spent 15 minutes creating exFAT from HFS drive.

    Kind of nightmare, Sierra Disk utility were quite reliable, why did they have to screw up old functionality is not clear to me.
     
  9. SteelBlueTJ macrumors 6502

    Joined:
    Apr 2, 2012
    Location:
    USA
    #9
    I am also having an absolute nightmare with this all day. I bought a new WD 4TB external and tried several hours trying to get it to reformat. It fails every time. Now when I try to mount it, I get "The disk you inserted was not readable by this computer." Everything is grayed out in disk utility and I can't do anything. This is the 2nd hard drive I've tried to do this with after returning the first thinking something was wrong with the drive, but now clearly it is High Sierra. There's just no way to format external drives anymore. I don't own a windows computer either. How could Apple overlook this important issue?
     
  10. oscarodas thread starter macrumors regular

    Joined:
    May 7, 2013
    Location:
    Sydney Australia
    #10
    You are spot on, I did follow the steps and was able to format my drive, also I noticed that with the new build (Beta 6) I get more format options, i.e. Ms_Dos.
     
  11. mmcinto58 macrumors newbie

    Joined:
    Dec 10, 2017
    #11
    I too bought the WD Passport 4TB. I too was not able to erase or format it. The first time I tried, it unmounted the drive, and then gave the error
    “Disk too large for partition scheme, failed”

    I found this thread, used the 2 step process above. IT WORKED after a few tries.

    Once I had a first success, I tried again. I erased it with a new name, it worked quickly and has worked every time after that.
     
  12. neliason macrumors 6502

    Joined:
    Oct 1, 2015
    #12
    I had the same problem with a WD Passport. Another option is to use the Western Digital utility to reformat the drive to HFS+. That worked for me as detailed in this thread:

    https://forums.macrumors.com/thread...port-usb-drive-time-machine-problems.2093304/
     
  13. ccwestcliff macrumors member

    Joined:
    Sep 19, 2012
    Location:
    Toronto, ON
    #13
    If someone else stumbles across this thread, as I did just today (with the 4TB MyBook and HS), I also used this tool: https://support.wdc.com/downloads.aspx?p=157 and it formatted it to HFS+ in no time!
     
  14. barnyreed macrumors newbie

    Joined:
    Jan 23, 2018
    Location:
    Australia
    #14
    I had this problem today, and lost half a day trying to work it out. Got onto a helpful dude at apple who sorted out the problem, well not the problem, but a fairly easy workaround in terminal. I made notes and am pasting them in below in case they can help anyone else:

    The disk has a higher level partition that the High Sierra (disk utility) doesn’t’t know how to delete. So he showed me how to totally erase the disk in Terminal, and then format it.

    It’s only three terminal commands

    First you need to unmount the NTFS disk, so look in disk utilities to see what device it is

    Disk Utility.png

    the device is called disk3s2, but you just want to call it disk3 (leave out the s2), or disk2, or whatever it is coming up as.

    open terminal and enter the code below, changing disk3 to whatever your device is:


    diskutil unmountDisk force disk3


    You should get something saying “Forced unmount of all volumes on disk3 was successful” if all goes well.
    Then you need to totally erase the disk, removing the microsoft higher level partition, so in terminal run the following command (again, replace the disk number with the appropriate number). It will prompt you for your password, so type it in and hit return:


    sudo dd if=/dev/zero of=/dev/rdisk3 bs=1024 count=1024


    You should get a result that looks like this


    “1024+0 records in
    1024+0 records out
    1048576 bytes transferred in 0.673985 secs (1555785 bytes/sec)”

    Now you need to partition the disk as Mac os journaled, so run the following command, and again change the disk number where appropriate, and change the name in the quote marks to whatever you want to call your disk:


    diskutil partitionDisk disk3 GPT JHFS+ "ENT" 0g



    Then you will see the progress as it formats it, then the disk will mount on the desktop and you’re ready to go.
     
  15. neliason macrumors 6502

    Joined:
    Oct 1, 2015
    #15
    Glad that worked. Unfortunately Disk Utility in High Sierra is a disaster. It is shameful. I had an external drive that had two partitions. I wanted to resize (expand) one partition and Disk Utility would say it completed the task but did nothing.
     
  16. zipkeys88 macrumors newbie

    Joined:
    Jan 26, 2018
    #16
    --- Post Merged, Jan 26, 2018 ---
    This worked! Thank you, thank you, thank you!

    I was afraid to mess with Terminal, but I copied and pasted your commands, changing the disk name and IT WORKED! Thanks!
     
  17. ry-guy macrumors member

    ry-guy

    Joined:
    Sep 24, 2015
    Location:
    Newport Beach, CA
    #17
    Use the Terminal to reformat.
    Check for the exact name of the disk:

    sudo diskutil list

    Force format the disk:

    sudo diskutil erasedisk JHFS+ Untitled /dev/disk<number>

    From another thread, this worked for me.

    Although I did this from Sierra, to an external drive BEFORE upgrading to High Sierra
     
  18. cabinum macrumors newbie

    Joined:
    Jan 30, 2018
    Location:
    Clover, South Carolina USA
    #18
    barnyreed - Thank you! Completely frustrated by this yesterday, and your fix worked like a charm.
     
  19. jayducharme macrumors 68040

    jayducharme

    Joined:
    Jun 22, 2006
    Location:
    The thick of it
    #19
    I found this support thread on Apple's site. Apparently, High Sierra's Disk Utility now hides the actual disk, which is what has to be formatted. When you change the view setting, you can format the physical drive.

    https://discussions.apple.com/message/32687232#32687232
     
  20. toru173 macrumors regular

    Joined:
    Apr 5, 2007
    #20
    I've used dd regularly to nuke the partition table of disks that won't format. Well done to your Genius for demonstrating this handy utility! It's particularly useful to rebuild a fusion array where one member has failed and the disk has been replaced, but the other member is still looking for the original disk
     
  21. Djdre22 macrumors newbie

    Djdre22

    Joined:
    Feb 7, 2018
    #21
    --- Post Merged, Feb 7, 2018 ---
    I received an error code. “Error: -69760: Unable to write to the last block of the device”. What should I do next?
     
  22. cupero macrumors newbie

    Joined:
    Feb 12, 2018
    #22
    This worked in no time. Thanks.
     
  23. Max Helix macrumors newbie

    Joined:
    Feb 28, 2018
    #23
    It worked. Surprised. Fast. Simple. Thank you barnyreed.
     
  24. DannyG776 macrumors newbie

    DannyG776

    Joined:
    Mar 1, 2018
    #24
    THANK YOU! This helped me out so much! I was racking my brain trying to figure it out and stumbled across your post. It works like a champ now!
     
  25. jayducharme macrumors 68040

    jayducharme

    Joined:
    Jun 22, 2006
    Location:
    The thick of it
    #25
    You're welcome. It drove me nuts as well. It was an uncharacteristic change from Apple, seeing as how formatting external drives isn't that rare an occurrence. The least Apple could have done was make the solution more obvious somehow. I shouldn't have to spend hours searching forums to figure out how to format a drive.
     

Share This Page