HL-2170W Laser Printer not working. HELP!

Discussion in 'Mac Accessories' started by jeonyx89, Sep 18, 2008.

  1. jeonyx89 macrumors newbie

    Joined:
    Sep 18, 2008
    #1
    So, I was trying to print a paper off my macbook today, and for some reason it wouldn't print. I ran a utility scan that showed that the printer was hooked up and receiving and sending signals, but I keep getting an error message saying that the Printer is offline! This happened right after the OS X 10.5.5 update. Has anyone had any problems like this too? The printer in question is the Brother HL-2170W laser printer.
     
  2. nanofrog macrumors G4

    Joined:
    May 6, 2008
    #2
    Have you tried:
    1. Check the print queue, and make sure it's empty.
    2. Turn the printer off.
    3. Power the computer down
    4. Wait 15 sec, turn on printer, and restart

    Simple, but can be effective. ;)
     
  3. kdaddy macrumors newbie

    Joined:
    Sep 18, 2008
    #3
    Update killed my printing capability

    Same problem here, also with a Brother HL-2170W. And I have hooked it up to my other system that I had not updated, and it works just fine. The printer is totally fine. Anyone have any suggestions?
     
  4. balkan72 macrumors newbie

    Joined:
    Sep 18, 2008
    #4
    Uh-oh, same problem here. I just updated 10.5.5 today and ever since I can't print. I get the same offline message. Let me know if you discover a fix!

     
  5. jeonyx89 thread starter macrumors newbie

    Joined:
    Sep 18, 2008
    #5
    I tried everything, even switching out the cables and such, and still NOTHING. Then, I called Brother. It turns out that this incident is pretty wide spread. The tech guy on the other line said basically that the latest OS X update is the problem and that they are working on a solution. They said that it could take a week or so.
     
  6. gotzero macrumors 68040

    Joined:
    Jan 6, 2007
    Location:
    Mid-Atlantic, US
    #6
    I use the same printer, and have two computers upgraded to 10.5.5. Both print fine wirelessly. I would recommend trying to print wirelessly or over ethernet.

    The wireless capabilities of this printer are fantastic.
     
  7. balkan72 macrumors newbie

    Joined:
    Sep 18, 2008
    #7
    Unfortunately, the wireless doesn't work for me. All I have for my router is an Airport Express and apparently that's not good enough.

     
  8. wotsapc macrumors newbie

    Joined:
    Nov 9, 2008
    #8
    AAAaaarrggghhh!

    I have just bought one of these printers, installed the latest driver for Leopard off the Brother site and it prints a beautiful test page but won't print anything from my imac 10.5.5. I get the 'printer is offline' error.

    Does anyone know if there is a fix to this yet or do I have to pay $1.99 a minute to vent my spleen at the Brother helpdesk? :mad:
     
  9. SnowLeopard2008 macrumors 604

    SnowLeopard2008

    Joined:
    Jul 4, 2008
    Location:
    Silicon Valley
    #9
    really? I have 10.5.5 and the same printer. Works great. Just install the printer driver from their website.
     
  10. wotsapc macrumors newbie

    Joined:
    Nov 9, 2008
    #10
    Got it sorted - I had the latest leopard driver from the website but still had the 'offline' error. I went back to the brother site and found out that you have to do a firmware update as well. My printer when I got it was 1.09 it's now 1.12 (from the printer setting printout) and works perfectly.

    Although I had to go into windoze via bootcamp to install the ROM upgrade as I got an error while doing it in OSX. All good now though - running through USB.

    Can anyone tell me if I can connect this printer to the mac via airport? Or does it have to go via a wireless router? I haven't had any experience with airport and don't really know what it's for.

    Cheers
     
  11. sickmacdoc macrumors 68020

    sickmacdoc

    Joined:
    Jun 14, 2008
    Location:
    New Hampshire
    #11
    Whoops- I typed too long and you beat me with the answer but I will leave my response to provide direct links to anyone else that needs the solution! :eek:

    No- you can just send the money to me- I can put it to better use! :D:D

    Seriously, the answer to this lies in a necessary firmware update to deal with 10.5.5.

    Check out the last post on the pre-existing thread below on the issue which provides a link to the solution Brother provided to the user who wrote to them about it and found out that it was not just a driver issue. That must do the trick, as there were no further posts! ;)

    See: http://forums.macrumors.com/showthread.php?t=564992&highlight=2170w

    BTW- I just noticed that the post immediately before the one I mentioned above has a link directly to Brother's website page concerning the Brother 10.5.5 firmware fix
     
  12. wotsapc macrumors newbie

    Joined:
    Nov 9, 2008
    #12
    Thanks for that - USB printing is fine now but having a bit of trouble setting up wireless printing...
     
  13. rd5590 macrumors newbie

    Joined:
    Jan 21, 2009
    #13
    Brother HL-2170W

    Very similiar problems on a PC. The core problem is the install doesn't handoff to the OS the IP address of the printer.
    I finally figured this out. Do the "cable" install. After it discovers the printer etc you will get to a screen during the driver part of the install that will ask you how to find the printer. The "recommended" list method is a deadend! Instead, check the IP address option and input that.. You can get the IP address of the printer from the test page which should have already printed.(Its probably 192.168.2.3). I run XP and it solved the problem. I suspect its also the answer for Macs and Vista as well.

    I have also had success by doing the "cable" install, then when its done, deleting the printer in Printers and Faxes, then doing a manual install (you still need the IP address). I am using two computers to go to this printer and it flies. Great speed.
     
  14. uhrinator macrumors newbie

    Joined:
    Oct 2, 2008
    #14
    my mac won't find the printer wirelessly when I follow the directions. I am using an airport extreme. Can anyone help?
     

Share This Page