HL2 crashes on my Mac

Discussion in 'Mac and PC Games' started by ionsko, Feb 11, 2009.

  1. ionsko macrumors newbie

    Joined:
    Feb 11, 2009
    #1
    Hi everybody,

    I'm new to this so please don't be hard on me.

    Couple of days ago I got Crossover and then the HL2 game, which I ran together with Crossover.
    Got it installed and everything but now...

    My Half Life 2 crashes at startup, what's that all about? Some kind of sound problem? cuz..

    It keeps loading until I get to the menu where some sound lagg and then it shuts down without any messege.

    I'm eager to play this game so could someone please tell me what to do? Or what this might be?

    Is there some settings I should change in the Launch options for HL2 in the Steam Games Menu?

    (Mac OS X 2.1 Ghz Intel Core 2 Duo, 1GB 667 MHz DDR2 SDRAM, Macbook)
     
  2. aznguyen316 macrumors 68020

    aznguyen316

    Joined:
    Oct 1, 2008
    Location:
    Tampa, FL
    #2
    I had this issue just yesterday on my mac via crossover games.

    First do you have the intel x3100?

    A couple things you can do but since we don't have the same chipset we'll have to see what works best for you.

    I assume you're using steam, so right click on Hl2 and click properties then click launch properties. enter this in w/o quotes

    "-console" = this allows you to skip the graphics rendering to get you to the screen to load up options and video settings

    if you're x3100 also enter this in the launch properties "-dxlevel 70" and "-window" is good too

    so your line shows "-console -dxlevel 70 -window" and maybe some other things, feel free to copy paste it.

    when you get into the game to go to options, turn SHADER details to LOW, and shadows to LOW and whatever else to maybe medium and turn OFF AA. After you apply those settings, quit out.

    go back to your launch properties and REMOVE -console and -dxlevel 70 and see if it will load in normally. My issue I found was I needed -dxlevel 81 and turn shadows to low so it wouldn't close out, this was only an issue for HL2 as the rest of the orange box ran FINE w/o ANY launch properties. If itdoesn't work, try -dxlevel 81 and change settings again to what I said and remove etc.

    good luck, let me know
     
  3. fiercetiger224 macrumors 6502a

    Joined:
    Jan 27, 2004
    #3
    The problem might be because you have a Macbook. It has an integrated graphics solution, instead of a dedicated graphics card, which hinders performance greatly. If it was a Macbook Pro, that would be a different story. Another problem lies in the fact that you're using Crossover, which is not considered to be a 100% compatible source for running Windows apps and games.

    Half-Life 2 is still a demanding game, even though it is almost 5 years old. A Macbook with Intel accelerated graphics can only do so much. If you really want to play it, you might want to start with Boot Camp, install Windows XP, and try it from there. Running the game natively will yield much better results than any kind of virtualization solution.
     
  4. aznguyen316 macrumors 68020

    aznguyen316

    Joined:
    Oct 1, 2008
    Location:
    Tampa, FL
    #4
    Although the Boot Camp statement is correct, my Orange Box runs better in that, Crossover works wonderful and allows me to play w/o rebooting which is a big plus.

    The MacBook x3100 CAN handle HL2 with proper settings adjustments w/o hardly any problems. I'm awaiting response from the OP, but don't count out the Intel chipset. If it was the GMA950, then you'd be correct as that would not work for source engine.
     
  5. ionsko thread starter macrumors newbie

    Joined:
    Feb 11, 2009
    #5
    Hi guys, and thanks for being here..

    I was kinda hoping to get a simple solution on this.. :/

    From what I've been reading on the internet, people say they can play HL2 totally fine on a Macbook such as mine when you're running it through Crossover. But not me? So I ask you guys, why?

    I tried the - console thing where you set your graphics lower and all that so that doesn't seem to be the issue for me.

    Anyway, here's my launch options and hopefully you'll know what's wrong with it:

    -novid +mat_hdr_level 0 -window -dxlevel 81 cl_drawmonitors 0 -width 1024 -height 768 -console

    Oh and btw. Maybe I should point out that when HL2 crashes and I get kicked back to desktop and steam - my screen gets a little blue when I'm targeting my Steam window with my cursor, but when i click outside of it, on the desktop it gets back to normal color.... Whatsup with that?

    Another thing, MacBook x3100? What do you mean by that? How can I look that up? I think my Macbook should manage HL2 :(
     
  6. aznguyen316 macrumors 68020

    aznguyen316

    Joined:
    Oct 1, 2008
    Location:
    Tampa, FL
    #6
    what model year is your laptop? late 2007? X3100 is the graphics or GMA950. I think with the 2.1Ghz it's x3100 if it's a whitebook.

    try -dxlevel 70 and did you lower the settings for Shaders and shadows? also a + before the monitors thing. I'm pretty sure it's the direct x level needs to be lowered b/c intel doesn't do shaders.. anyway, try it please and report!

    copy paste that, change the settings to low apply and then quit out then put this into your launch properties

    Launch the game again and see if it goes to the regular title screen. I would hope that does the trick. Tip, put your MacBook specs into your sig for easier help on future issues.
     
  7. Dagless macrumors Core

    Dagless

    Joined:
    Jan 18, 2005
    Location:
    Fighting to stay in the EU
    #7
    My MB with integrated graphics runs HL2 with everything set to full, even Episode 1 and 2 and they run perfectly.
    It really is just Crossover crippling performance again.

    I wouldn't say it's a demanding game either. Not by a long shot.
     
  8. aznguyen316 macrumors 68020

    aznguyen316

    Joined:
    Oct 1, 2008
    Location:
    Tampa, FL

Share This Page