HomePod Home App Issue with HomePod

Discussion in 'HomeKit, HomePod, CarPlay, Home & Auto Technology' started by PTVMan, Feb 9, 2018.

  1. PTVMan macrumors 6502a

    Joined:
    Sep 20, 2012
    #1
    When I try to go to settings in the Home App for my HomePod it shows the icon square for the HomePod, but it has an exclamation mark and say No Response in red letters. Yet the HomePod is currently playing music and Siri is responding to my requests. Any ideas?
     
  2. cynics macrumors G4

    Joined:
    Jan 8, 2012
    #2
    Do you have any other HomeKit devices?

    I would start with rebooting the iPhone. On occasion I get that with a HomeKit device on my iPad, a reboot fixes it.
     
  3. ovrlrd macrumors 65816

    ovrlrd

    Joined:
    Aug 29, 2009
    #3
    I am having this exact same issue right now. I have tried resetting the HomePod several times. Reset the settings for it and all.

    I also completely removed my WiFi (forget the network) and set it up using a AirPort Base Station I don’t use instead. It still does it.

    I restarted my iPhone, restarted my iPad, restarted everything countless times.

    The HomePod works fine, it obviously connects to WiFi and responds fine. It is really a bug in HomeKit from what I can tell. It might even be on Apple’s side for all I know.

    Please let me know if you find a fix.
    --- Post Merged, Feb 9, 2018 ---
    My other HomeKit devices work fine. It is definitely just the HomePod. I even removed my entire home from HomeKit thinking that might fix it. Still no luck.
     
  4. The Martian macrumors regular

    The Martian

    Joined:
    Mar 21, 2016
    #4
    I've had a similar problem with my Homekit devices but if I reset my Hue Hub and manually closed the Home App it finally came back. Id swipe up on the Home App to close it and see what happens.
     
  5. ovrlrd macrumors 65816

    ovrlrd

    Joined:
    Aug 29, 2009
    #5
    Yeah every time I reset the HomePod, I would also quit the app. Tried restarting every combination of things and no luck.

    Funny enough the HomePod actually manages to load all the extra settings in the details, which to me means it connects to HomeKit just fine, but it won't let me change anything. If I delete the HomePod from HomeKit it restarts the HomePod into setup mode.

    I just can't tell which part of everything is broken. Hopefully it is something that Apple can fix and isn't something too obscure. I am actually glad someone else had the issue.
     
  6. groovyf macrumors 6502

    Joined:
    Dec 15, 2010
    Location:
    Halifax, UK
    #6
    Do you see the Speakers section after tapping the location arrow (top left) in the Home app?
    Is the HomePod connected as a Home Hub too?
     
  7. ovrlrd macrumors 65816

    ovrlrd

    Joined:
    Aug 29, 2009
    #7
    Yep it shows up there. I can even change those settings there. It shows the HomePod is up to date as well.

    Like I said, all functionality and details are there, except the part where I can’t change any settings in the HomePod details and it says “No Response” with the exclamation icon.

    The HomePod is the home hub right now I think, since I deleted my entire Home from Homekit and set it up with nothing else connected.
     
  8. krazygreekguy macrumors newbie

    krazygreekguy

    Joined:
    Feb 28, 2018
    #8
    Have you resolved this issue? I have been having the same exact issue since day one of having the HomePod and I have been using HomeKit since it has first come out. Besides the occasional hiccups, it generally worked fine, that is until I setup the HomePod and I have lost remote functionality and the apple tv HomeKit section has disappeared. Been working with apple now for 3 weeks and they have no idea how to help me. This is ridiculous.
     
  9. Arran macrumors 601

    Arran

    Joined:
    Mar 7, 2008
    Location:
    Atlanta, USA
    #9
    I’ve been having the exact same problem as everyone else here. After a dozen or so resets of the HomePod, I got to the stage where it was completely bricked: It wouldn’t respond to my iPhone X when I brought it close to start setup. Just before it became bricked, I saw numeric error codes on the phone setup app. Subsequent HomePod resets (press top button while powering up) left the HomePod bricked.

    Luckily I tried setup with a different phone - and for some inexplicable reason it worked. However, the HomeKit hub problem persisted.

    After 3 frustrating weekends of trying to get HomeKit hub working, I reluctantly returned it to Best Buy. I really liked the sound and siri experience, but part of my justification for buying this was that it would be my first HomeKit hub.

    FWIW, I already have several Apple TV’s (4K and gen 4) but never tried setting them up as HomeKit hubs before. As part of this sorry process, I tried but was unable to. That got me wondering if it’s because I have TWO Apple ID’s: One for App Store and iTunes Store purchases (including iTunes Match) which is shared with my wife, and my own personal Apple ID for email, contacts, etc. It’s strange, because when I was setting up my HomePod, the iPhone always recognized and offered to transfer BOTH Apple ID’s settings to the HomePod. You’d think that was a positive sign, yes?

    Anyway, I gave up and got my money back. I’ll look at gen 2 whenever it comes out.
     
  10. TrueBlou macrumors demi-god

    TrueBlou

    Joined:
    Sep 16, 2014
    Location:
    Scotland
    #10
    The different Apple ID’s won’t make a difference. I use two, one for iTunes and so on and one for my email and the rest. Only because Apple still won’t let me combine them after god knows how many years.

    Anyway, probably a stupid question, but you do have two-factor authentication enabled? It’s required for the Home Hub features.
    Also stupid and probably the first thing you checked, but with your Apple TV, make sure the correct account is being used for the correct thing in settings.
    Once when I set mine up it used my iTunes details for the HomeKit login details, which should have been my other account, so I had to change that.
     
  11. Arran macrumors 601

    Arran

    Joined:
    Mar 7, 2008
    Location:
    Atlanta, USA
    #11
    Thanks. Good to know two separate ID's aren't causing this. What on earth is, however?

    Two factor auth is enabled for both IDs and as far as the Apple TV 4k goes, I've tried resetting it numerous times and also tried both Apple IDs, again several times with resets in-between. Nothing enabled any homekit hub options. It's a real head-scratcher.

    That said, I've been happily using the Philips Hue app for out-of-home control of lights for years - so I'll just continue with that for now. I'm worn-out trying to get this to work.
     
  12. jbuccino macrumors newbie

    Joined:
    Dec 9, 2006
    #12
    I had exactly the same problem. I tried deleting the HomePod from the Home App and re-adding. I tried a factory reset. Both times the set up worked fine and the HomePod showed up in the Home App but within seconds it showed the "No Response" again. On a whim I tried re-locating the HomePod and instantly it showed up in the Home App and it continues to work fine! The only thing I can think of is that it was originally close to my large Paradigm subwoofer and so possibly it was an interference issue. I hope this helps others.
     
  13. fatboyslick macrumors regular

    Joined:
    Jun 23, 2010
    #13
    Im now having this problem plus my two homepods cant work independantly. Theyre not stereo paired but refuse to play different music together at the same time
     
  14. Topfry, Sep 28, 2018
    Last edited: Sep 28, 2018

    Topfry macrumors member

    Joined:
    Apr 19, 2011
    #14
    I had problems with this after updating to iOS 12, to the point where the home app would crash every time I opened it. It worked fine on the iPad but iPhone 7 was unusable. I did all the above, but what sorted it was signing out of iCloud (being careful to save all the settings) and signing back in. It took about 3 attempts, and it had to be done methodically, but completely resolved the problem.
    Unplug HomePod - sign out of iCloud - restart homepod - sign into iCloud - setup HomePod
    I would say that there are still some problems with syncing with HomePod particularly after airplay 2 was introduced, where iOS devices don’t always seem to update with what is happening on the HomePod, and controlling it with an iOS device is patchy. But early days I guess...
     

Share This Page